summaryrefslogtreecommitdiff
path: root/sci-chemistry/gromacs/gromacs-2022.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2022.5-r1.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.5-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2022.5-r1.ebuild b/sci-chemistry/gromacs/gromacs-2022.5-r1.ebuild
index 33f192f4a04f..9a91a5cbac88 100644
--- a/sci-chemistry/gromacs/gromacs-2022.5-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.5-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
CMAKE_MAKEFILE_GENERATOR="ninja"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=no
@@ -17,7 +17,7 @@ if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="
https://gitlab.com/gromacs/gromacs.git
https://github.com/gromacs/gromacs.git
- git://git.gromacs.org/gromacs.git"
+ "
[[ ${PV} = 9999 ]] && EGIT_BRANCH="master" || EGIT_BRANCH="release-${PV:0:4}"
inherit git-r3
else
@@ -104,7 +104,7 @@ src_unpack() {
else
git-r3_src_unpack
if use test; then
- EGIT_REPO_URI="git://git.gromacs.org/regressiontests.git" \
+ EGIT_REPO_URI="https://gitlab.com/gromacs/gromacs-regressiontests.git" \
EGIT_BRANCH="${EGIT_BRANCH}" \
EGIT_CHECKOUT_DIR="${WORKDIR}/regressiontests"\
git-r3_src_unpack
@@ -149,8 +149,8 @@ src_prepare() {
DOC_CONTENTS="Gromacs can use sci-chemistry/vmd to read additional file formats"
if use build-manual; then
# try to create policy for imagemagik
- mkdir -p ${HOME}/.config/ImageMagick
- cat >> ${HOME}/.config/ImageMagick/policy.xml <<- EOF
+ mkdir -p "${HOME}"/.config/ImageMagick
+ cat >> "${HOME}"/.config/ImageMagick/policy.xml <<- EOF
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policymap [
<!ELEMENT policymap (policy)+>
@@ -327,7 +327,7 @@ src_install() {
pkg_postinst() {
einfo
einfo "Please read and cite gromacs related papers from list:"
- einfo "https://www.gromacs.org/Gromacs_papers"
+ einfo "https://www.gromacs.org/articles.html"
einfo
readme.gentoo_print_elog
}