summaryrefslogtreecommitdiff
path: root/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2021.9999.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
index ebd3a798340c..ac7420b81358 100644
--- a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
@@ -161,17 +161,18 @@ src_prepare() {
src_configure() {
local mycmakeargs_pre=( ) extra fft_opts=( )
+ local acce="AUTO"
if use custom-cflags; then
#go from slowest to fastest acceleration
- local acce="None"
+ acce="None"
if (use amd64 || use x86); then
- use cpu_flags_x86_sse2 && acce="SSE2"
- use cpu_flags_x86_sse4_1 && acce="SSE4.1"
- use cpu_flags_x86_fma4 && acce="AVX_128_FMA"
- use cpu_flags_x86_avx && acce="AVX_256"
- use cpu_flags_x86_avx2 && acce="AVX2_256"
- use cpu_flags_x86_avx512f && acce="AVX_512"
+ use cpu_flags_x86_sse2 && acce="SSE2"
+ use cpu_flags_x86_sse4_1 && acce="SSE4.1"
+ use cpu_flags_x86_fma4 && acce="AVX_128_FMA"
+ use cpu_flags_x86_avx && acce="AVX_256"
+ use cpu_flags_x86_avx2 && acce="AVX2_256"
+ use cpu_flags_x86_avx512f && acce="AVX_512"
elif (use arm); then
use cpu_flags_arm_neon && acce="ARM_NEON"
elif (use arm64); then