summaryrefslogtreecommitdiff
path: root/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
index f55212f3bdc7..fb8e9270106c 100644
--- a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -237,7 +237,7 @@ src_configure() {
local gpu=( "-DGMX_GPU=OFF" )
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -254,7 +254,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON