summaryrefslogtreecommitdiff
path: root/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
index b04308aaa907..bf9f493d1163 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
@@ -8,15 +8,15 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
inherit bash-completion-r1 cmake cuda readme.gentoo-r1 toolchain-funcs xdg-utils
SRC_URI="
- http://ftp.gromacs.org/gromacs/${PN}-${PV/_/-}.tar.gz
- doc? ( http://ftp.gromacs.org/manual/manual-${PV/_/-}.pdf )
- test? ( http://ftp.gromacs.org/regressiontests/regressiontests-${PV/_/-}.tar.gz )"
+ https://ftp.gromacs.org/gromacs/${PN}-${PV/_/-}.tar.gz
+ doc? ( https://ftp.gromacs.org/manual/manual-${PV/_/-}.pdf )
+ test? ( https://ftp.gromacs.org/regressiontests/regressiontests-${PV/_/-}.tar.gz )"
KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux ~x64-macos"
ACCE_IUSE="cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_fma4 cpu_flags_x86_avx cpu_flags_x86_avx2"
DESCRIPTION="The ultimate molecular dynamics simulation package"
-HOMEPAGE="http://www.gromacs.org/"
+HOMEPAGE="https://www.gromacs.org/"
# see COPYING for details
# https://repo.or.cz/w/gromacs.git/blob/HEAD:/COPYING
@@ -50,6 +50,7 @@ RDEPEND="${CDEPEND}"
REQUIRED_USE="
|| ( single-precision double-precision )
cuda? ( single-precision )
+ opencl? ( single-precision )
cuda? ( !opencl )
mkl? ( !blas !fftw !lapack )
${PYTHON_REQUIRED_USE}"
@@ -109,11 +110,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl