summaryrefslogtreecommitdiff
path: root/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild')
-rw-r--r--sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild b/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
deleted file mode 100644
index 64e36c7c268f..000000000000
--- a/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Periodic table application for Linux"
-HOMEPAGE="https://sourceforge.net/projects/gperiodic/"
-SRC_URI="http://www.frantz.fi/software/${P}.tar.gz"
-
-KEYWORDS="amd64 x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="nls"
-
-RDEPEND="
- sys-libs/ncurses:0
- x11-libs/gtk+:2
- x11-libs/cairo[X]
- nls? ( sys-devel/gettext )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-nls.patch
- sed \
- -e '/Encoding/d' \
- -i ${PN}.desktop || die
-}
-
-src_compile() {
- local myopts
- use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
- emake CC=$(tc-getCC) ${myopts}
-}
-
-src_install() {
- local myopts
- use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
- emake DESTDIR="${D}" ${myopts} install
- dodoc AUTHORS ChangeLog README NEWS
- newdoc po/README README.translation
-}