summaryrefslogtreecommitdiff
path: root/sci-chemistry/easychem/easychem-0.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/easychem/easychem-0.6-r1.ebuild')
-rw-r--r--sci-chemistry/easychem/easychem-0.6-r1.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/sci-chemistry/easychem/easychem-0.6-r1.ebuild b/sci-chemistry/easychem/easychem-0.6-r1.ebuild
index 9fbce1815123..4d9d43bcf619 100644
--- a/sci-chemistry/easychem/easychem-0.6-r1.ebuild
+++ b/sci-chemistry/easychem/easychem-0.6-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Chemical structure drawing program - focused on presentation"
HOMEPAGE="http://easychem.sourceforge.net/"
@@ -12,18 +12,22 @@ SRC_URI="mirror://sourceforge/easychem/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="
- x11-libs/gtk+:2
app-text/ghostscript-gpl
- media-gfx/pstoedit"
-DEPEND="${RDEPEND}
+ media-gfx/pstoedit
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-lang/perl
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${PV}-gentoo.patch )
src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
+ default
tc-export CC
}