summaryrefslogtreecommitdiff
path: root/sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild')
-rw-r--r--sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild b/sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild
new file mode 100644
index 000000000000..63f38eed67d2
--- /dev/null
+++ b/sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Build lists of collections of interacting items"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/index.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${PN}.${PV}.src.tgz"
+S="${WORKDIR}"/${PN}1.3src
+
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-ldflags.patch
+ "${FILESDIR}"/${PV}-includes.patch
+ "${FILESDIR}"/${PV}-drop-registers.patch
+)
+
+src_configure() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ newbin ${PN} molprobity-${PN}
+ dodoc README.cluster
+}