summaryrefslogtreecommitdiff
path: root/sci-chemistry/chemex/chemex-0.6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/chemex/chemex-0.6.1-r1.ebuild')
-rw-r--r--sci-chemistry/chemex/chemex-0.6.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/chemex-0.6.1-r1.ebuild b/sci-chemistry/chemex/chemex-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..9e4f47aafc99
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-0.6.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DISTUTILS_SINGLE_IMPL="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/chemex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/matplotlib-1.1[${PYTHON_USEDEP}]
+ || (
+ dev-python/numpy-python2[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ >=sci-libs/scipy-0.11[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ # Fix quotes to detect the version properly
+ sed -i -e 's/matplotlib>=1.3.1/matplotlib>="1.3.1"/' setup.py || die
+ distutils-r1_python_prepare_all
+}