summaryrefslogtreecommitdiff
path: root/sci-chemistry/ccpn/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/ccpn/files')
-rw-r--r--sci-chemistry/ccpn/files/2.3.1-parallel.patch38
-rw-r--r--sci-chemistry/ccpn/files/analysis8
-rw-r--r--sci-chemistry/ccpn/files/dangle8
-rw-r--r--sci-chemistry/ccpn/files/dataShifter8
-rw-r--r--sci-chemistry/ccpn/files/depositionFileImporter8
-rw-r--r--sci-chemistry/ccpn/files/eci8
-rw-r--r--sci-chemistry/ccpn/files/extendNmr8
-rw-r--r--sci-chemistry/ccpn/files/formatConverter8
-rw-r--r--sci-chemistry/ccpn/files/pipe2azara8
-rw-r--r--sci-chemistry/ccpn/files/xeasy2azara8
10 files changed, 110 insertions, 0 deletions
diff --git a/sci-chemistry/ccpn/files/2.3.1-parallel.patch b/sci-chemistry/ccpn/files/2.3.1-parallel.patch
new file mode 100644
index 000000000000..fcf44707e082
--- /dev/null
+++ b/sci-chemistry/ccpn/files/2.3.1-parallel.patch
@@ -0,0 +1,38 @@
+diff --git a/ccpnmr2.3/c/Makefile b/ccpnmr2.3/c/Makefile
+index 01fb25a..8e8e1fe 100644
+--- a/ccpnmr2.3/c/Makefile
++++ b/ccpnmr2.3/c/Makefile
+@@ -5,22 +5,22 @@ all: compile
+ compile: global structure analysis clouds dynamics bayes
+
+ global:
+- cd memops/global && $(MAKE)
++ $(MAKE) -C memops/global
+
+-structure:
+- cd ccp/structure && $(MAKE)
++structure: global
++ $(MAKE) -C ccp/structure
+
+-analysis:
+- cd ccpnmr/analysis && $(MAKE)
++analysis: global
++ $(MAKE) -C ccpnmr/analysis
+
+-clouds:
+- cd ccpnmr/clouds && $(MAKE)
++clouds: global
++ $(MAKE) -C ccpnmr/clouds
+
+-dynamics:
+- cd ccpnmr/dynamics && $(MAKE)
++dynamics: global
++ $(MAKE) -C ccpnmr/dynamics
+
+-bayes:
+- cd other/cambridge/bayes && $(MAKE)
++bayes: global
++ $(MAKE) -C other/cambridge/bayes
+
+ clean: global_clean structure_clean analysis_clean clouds_clean dynamics_clean bayes_clean
+
diff --git a/sci-chemistry/ccpn/files/analysis b/sci-chemistry/ccpn/files/analysis
new file mode 100644
index 000000000000..828ed4e64ae9
--- /dev/null
+++ b/sci-chemistry/ccpn/files/analysis
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -i -O ${CCPNMR_TOP_DIR}/ccpn/python/ccpnmr/analysis/AnalysisGui.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/dangle b/sci-chemistry/ccpn/files/dangle
new file mode 100644
index 000000000000..6d8a42e615de
--- /dev/null
+++ b/sci-chemistry/ccpn/files/dangle
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/cambridge/dangle/DangleGui.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/dataShifter b/sci-chemistry/ccpn/files/dataShifter
new file mode 100644
index 000000000000..c083960f2f60
--- /dev/null
+++ b/sci-chemistry/ccpn/files/dataShifter
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccpnmr/format/gui/DataShifter.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/depositionFileImporter b/sci-chemistry/ccpn/files/depositionFileImporter
new file mode 100644
index 000000000000..09505ccc4925
--- /dev/null
+++ b/sci-chemistry/ccpn/files/depositionFileImporter
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/pdbe/deposition/dataFileImport/dataFileImportGui.py $@
diff --git a/sci-chemistry/ccpn/files/eci b/sci-chemistry/ccpn/files/eci
new file mode 100644
index 000000000000..54d913348718
--- /dev/null
+++ b/sci-chemistry/ccpn/files/eci
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccpnmr/eci/EntryCompletionGui.py $*
diff --git a/sci-chemistry/ccpn/files/extendNmr b/sci-chemistry/ccpn/files/extendNmr
new file mode 100644
index 000000000000..a2fe4c997c7c
--- /dev/null
+++ b/sci-chemistry/ccpn/files/extendNmr
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O -i -O ${CCPNMR_TOP_DIR}/ccpn/python/extendNmr/ExtendNmrGui.py $@
diff --git a/sci-chemistry/ccpn/files/formatConverter b/sci-chemistry/ccpn/files/formatConverter
new file mode 100644
index 000000000000..6cb273612352
--- /dev/null
+++ b/sci-chemistry/ccpn/files/formatConverter
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccpnmr/format/gui/FormatConverter.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/pipe2azara b/sci-chemistry/ccpn/files/pipe2azara
new file mode 100644
index 000000000000..5a3710a134a7
--- /dev/null
+++ b/sci-chemistry/ccpn/files/pipe2azara
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccp/format/spectra/params/NmrPipeData.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/xeasy2azara b/sci-chemistry/ccpn/files/xeasy2azara
new file mode 100644
index 000000000000..7b73714c2fa5
--- /dev/null
+++ b/sci-chemistry/ccpn/files/xeasy2azara
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccp/format/spectra/params/XeasyData.py $1 $2 $3 $4 $5 $6