summaryrefslogtreecommitdiff
path: root/sci-chemistry/bkchem
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/bkchem')
-rw-r--r--sci-chemistry/bkchem/Manifest4
-rw-r--r--sci-chemistry/bkchem/bkchem-0.14.0_pre2-r2.ebuild40
-rw-r--r--sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch106
-rw-r--r--sci-chemistry/bkchem/metadata.xml8
4 files changed, 0 insertions, 158 deletions
diff --git a/sci-chemistry/bkchem/Manifest b/sci-chemistry/bkchem/Manifest
deleted file mode 100644
index db9b3239f21c..000000000000
--- a/sci-chemistry/bkchem/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX bkchem-0.14.0_pre2-nolauncher.patch 2967 BLAKE2B 0953c3c969bb2955f13de81db84eef2f24d6a3999b1f9e8d3ed837cf04718386eb44a2141f55f1775339856698d1c5242564177e998203110776128b7bfde87b SHA512 dbd7b8eef583c3b64dfc1755a3b5eae5eb8ab222454936636147de64e021166e29f915655f1acf2d7252983bf4873dc8f2fb69ca58b56955ab1ce07e8ec82789
-DIST bkchem-0.14.0-pre2.tar.gz 998916 BLAKE2B 07c01abb31325c3721cc478438c1b34f156bc589a186eeedd62b6ac058f8ec64b1ea86a3c25bb6ab8045e0aaa838f10c5d16b68516fdea5607795b64fb4c39bb SHA512 7fc3bbd7bfe27bc91cf69a98c347a3fb92f4ea25b45a13debd0646a6b02d7a40c5729ae1b2a9ac33c1049d6b90e38355c3cd80e06660a0a2fcc5dafb3514ef20
-EBUILD bkchem-0.14.0_pre2-r2.ebuild 888 BLAKE2B 68092928e3c841dcb59ffa485c0ab356116f69d24ffdb58d0e11140e3eaff2034dcf79981f386f08e73dd6e074c2789c75ce08899dad3caa81f4005dc726ddb3 SHA512 f6505dde2dee31398bfc5be9999e8f47313ac7fa2f477ec0dc8f425d25ee2fb0f8998f350f42d511cb6dcc16545c3e8030e164b9c1046d25c31080dba2413bf2
-MISC metadata.xml 271 BLAKE2B a446884cbe7a6789e0bcd82759f57bf1ab7b29c5ab714057ffa821c90f799d1fa9f9310c187ee4c3a8ae2476f6ea9d15f368045779f1581e68d02802c61c884c SHA512 3e6e6047a29e07123b81279cae1de17bc4bd4c3d7d8a8d26560114a18185f473d038fc220fa81c7213fa203ce197bad8b1c272d9b7e41cd770a953fa6308ff92
diff --git a/sci-chemistry/bkchem/bkchem-0.14.0_pre2-r2.ebuild b/sci-chemistry/bkchem/bkchem-0.14.0_pre2-r2.ebuild
deleted file mode 100644
index d6162080214b..000000000000
--- a/sci-chemistry/bkchem/bkchem-0.14.0_pre2-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-PYTHON_REQ_USE="tk"
-
-inherit distutils-r1 eutils versionator
-
-MY_P="${PN}-$(replace_version_separator 3 -)"
-
-DESCRIPTION="Chemical drawing program"
-HOMEPAGE="http://bkchem.zirael.org/"
-SRC_URI="http://bkchem.zirael.org/download/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LICENSE="GPL-2"
-IUSE="cairo"
-
-DEPEND="cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-nolauncher.patch
-)
-
-python_install() {
- distutils-r1_python_install "--strip=${ED}/_${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- python_foreach_impl python_newscript ${PN}/${PN}.py ${PN}
- make_desktop_entry bkchem BKChem "${EPREFIX}"/usr/share/${PN}/images/${PN}.png Science
-}
diff --git a/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch b/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch
deleted file mode 100644
index 202c47a9c74f..000000000000
--- a/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch
+++ /dev/null
@@ -1,106 +0,0 @@
- bkchem/bkchem.py | 24 +++++++++++++-----------
- setup.py | 23 -----------------------
- 2 files changed, 13 insertions(+), 34 deletions(-)
-
-diff --git a/bkchem/bkchem.py b/bkchem/bkchem.py
-index b336b9c..bcb68b0 100644
---- a/bkchem/bkchem.py
-+++ b/bkchem/bkchem.py
-@@ -1,3 +1,4 @@
-+#!/usr/bin/env python2
- #--------------------------------------------------------------------------
- # This file is part of BKChem - a chemical drawing program
- # Copyright (C) 2002-2009 Beda Kosata <beda@zirael.org>
-@@ -18,18 +19,19 @@
- #--------------------------------------------------------------------------
-
-
--"""this is just a starter of the application"""
-+#"""this is just a starter of the application"""
-
- ## support for loading from outside of bkchem dir
-
--import os_support, sys
-+from bkchem import os_support
-+import sys
- sys.path.insert( 1, os_support.get_module_path())
-
-
- ### now starting for real
-
--from singleton_store import Store
--import pref_manager
-+from bkchem.singleton_store import Store
-+from bkchem import pref_manager
-
- # at first preference manager
- Store.pm = pref_manager.pref_manager(
-@@ -78,13 +80,13 @@ else:
-
-
-
--import config
-+from bkchem import config
-
- if not config.debug:
- # checking of important modules availability
- # import modules
-- import import_checker
-- import messages
-+ from bkchem import import_checker
-+ from bkchem import messages
-
- # we need sets from the 2.3 version
- if not import_checker.python_version_ok:
-@@ -103,16 +105,16 @@ if not config.debug:
-
-
- #import Tkinter
--from main import BKChem
--from splash import Splash
--from singleton_store import Store
-+from bkchem.main import BKChem
-+from bkchem.splash import Splash
-+from bkchem.singleton_store import Store
-
- myapp = BKChem()
- myapp.withdraw()
-
- if __name__ == '__main__':
-
-- import messages
-+ from bkchem import messages
- enc = sys.getfilesystemencoding()
- if not enc:
- enc = sys.getdefaultencoding()
-diff --git a/setup.py b/setup.py
-index d4b2a21..2319216 100755
---- a/setup.py
-+++ b/setup.py
-@@ -91,26 +91,3 @@ if len( sys.argv) > 1 and sys.argv[1] == 'install' and '--help' not in sys.argv:
- print "file %s created" % config_name
-
-
-- # the executable
-- if not os.path.isdir( bin_dir):
-- try:
-- os.mkdir( bin_dir)
-- except:
-- print "ERROR: could not create directory %s" % bin_dir
-- sys.exit( 201)
-- exec_name = os.path.join( bin_dir, 'bkchem')
-- try:
-- file = open( exec_name, 'w')
-- except:
-- print "ERROR: couldn't open the file %s for write" % exec_name
-- sys.exit( 201)
-- file.write( "#!/bin/sh\n")
-- file.write( 'python %s "$@"\n' % strip_path( os.path.join( py_dir, "bkchem", "bkchem.py")))
-- file.close()
-- print "file %s created" % exec_name
-- try:
-- os.chmod( os.path.join( bin_dir, 'bkchem'), 5+5*8+7*8*8)
-- except:
-- print "ERROR: failed to make %s executable" % exec_name
-- sys.exit( 201)
-- print "file %s made executable" % exec_name
diff --git a/sci-chemistry/bkchem/metadata.xml b/sci-chemistry/bkchem/metadata.xml
deleted file mode 100644
index 8937bad0b175..000000000000
--- a/sci-chemistry/bkchem/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
- </maintainer>
-</pkgmetadata>