summaryrefslogtreecommitdiff
path: root/sci-calculators/pcalc/pcalc-5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/pcalc/pcalc-5.ebuild')
-rw-r--r--sci-calculators/pcalc/pcalc-5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-calculators/pcalc/pcalc-5.ebuild b/sci-calculators/pcalc/pcalc-5.ebuild
new file mode 100644
index 000000000000..398bb59b6c34
--- /dev/null
+++ b/sci-calculators/pcalc/pcalc-5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="the programmers calculator"
+HOMEPAGE="https://github.com/vapier/pcalc"
+SRC_URI="mirror://sourceforge/pcalc/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="sys-devel/flex"
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}