summaryrefslogtreecommitdiff
path: root/sci-calculators/datamash/datamash-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/datamash/datamash-1.5.ebuild')
-rw-r--r--sci-calculators/datamash/datamash-1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-calculators/datamash/datamash-1.5.ebuild b/sci-calculators/datamash/datamash-1.5.ebuild
new file mode 100644
index 000000000000..db1f765861fa
--- /dev/null
+++ b/sci-calculators/datamash/datamash-1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command-line program for basic numeric, textual and statistical operations"
+HOMEPAGE="https://www.gnu.org/software/datamash/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linux-crypto nls openssl"
+
+CDEPEND="
+ openssl? ( dev-libs/openssl )
+"
+RDEPEND="
+ ${CDEPEND}
+ nls? ( virtual/libintl )
+"
+BDEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with openssl) \
+ $(use_with linux-crypto)
+}