summaryrefslogtreecommitdiff
path: root/sci-calculators/bc-gh/bc-gh-5.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/bc-gh/bc-gh-5.0.0.ebuild')
-rw-r--r--sci-calculators/bc-gh/bc-gh-5.0.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/sci-calculators/bc-gh/bc-gh-5.0.0.ebuild b/sci-calculators/bc-gh/bc-gh-5.0.0.ebuild
new file mode 100644
index 000000000000..47aaece3ed37
--- /dev/null
+++ b/sci-calculators/bc-gh/bc-gh-5.0.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementation of POSIX bc with GNU extensions"
+HOMEPAGE="https://git.yzena.com/gavin/bc"
+SRC_URI="https://github.com/gavinhoward/bc/releases/download/${PV}/bc-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+S="${WORKDIR}/bc-${PV}"
+
+src_configure() {
+ EXECSUFFIX="-gh" PREFIX="${EPREFIX}/usr" ./configure.sh -GTl -sbc.banner -sdc.tty_mode || die
+}