summaryrefslogtreecommitdiff
path: root/sci-biology/tree-puzzle/files/tree-puzzle-5.2-configure-c99.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/tree-puzzle/files/tree-puzzle-5.2-configure-c99.patch')
-rw-r--r--sci-biology/tree-puzzle/files/tree-puzzle-5.2-configure-c99.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-biology/tree-puzzle/files/tree-puzzle-5.2-configure-c99.patch b/sci-biology/tree-puzzle/files/tree-puzzle-5.2-configure-c99.patch
new file mode 100644
index 000000000000..8c3834136af1
--- /dev/null
+++ b/sci-biology/tree-puzzle/files/tree-puzzle-5.2-configure-c99.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,7 +33,7 @@ int main (int argc, char **argv)
+ {
+ MPI_Init(&argc,&argv);
+ MPI_Finalize();
+-exit(0);
++return 0;
+ }
+ EOF
+
+@@ -105,7 +105,7 @@ cat > conftest.c <<EOF
+ int main (int argc, char **argv)
+ {
+ printf ("%s-%s", PACKAGE, VERSION);
+-exit(0);
++return 0;
+ }
+ EOF
+