summaryrefslogtreecommitdiff
path: root/sci-biology/seqan/seqan-2.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/seqan/seqan-2.4.0-r1.ebuild')
-rw-r--r--sci-biology/seqan/seqan-2.4.0-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-biology/seqan/seqan-2.4.0-r1.ebuild b/sci-biology/seqan/seqan-2.4.0-r1.ebuild
index 76a73d759bef..933b55e04eab 100644
--- a/sci-biology/seqan/seqan-2.4.0-r1.ebuild
+++ b/sci-biology/seqan/seqan-2.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,6 +37,10 @@ PATCHES=(
"${FILESDIR}"/${P}-cmake-add_library-static.patch
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use tools && tc-check-openmp
+}
+
pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]]; then
use tools && tc-check-openmp