summaryrefslogtreecommitdiff
path: root/sci-biology/pysam
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/pysam')
-rw-r--r--sci-biology/pysam/Manifest5
-rw-r--r--sci-biology/pysam/files/pysam-0.21.0-cython-3.patch24
-rw-r--r--sci-biology/pysam/pysam-0.22.1.ebuild (renamed from sci-biology/pysam/pysam-0.21.0.ebuild)20
3 files changed, 10 insertions, 39 deletions
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index 4a490595f41b..5c166b78848f 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1,5 +1,4 @@
-AUX pysam-0.21.0-cython-3.patch 946 BLAKE2B 6b74b084d4f0308a77266c748209a91aa23fc0f51635b45bb2e47efc7d1e2f4a67993305d0f12c74964add24ec49ebb8b56bff720aec065a76257bda5a677cdb SHA512 763bee599547059dfff39f7ae087402dfca67acabc048012663d6cd792c605d6dc07210f777d22e9373c086cd9cd468e7ae3060a501962157ba5f6971c8033a1
-DIST pysam-0.21.0.gh.tar.gz 3842829 BLAKE2B 83db290ec0bae71106276ed4f1721292c0d2fa55053c7451f0a8a79619b1c4d8444b99293ac5d8051bfb0b59e984e32a89798bab091e3a019b7c2a3fb7414d1c SHA512 b2ac986b6a352df1d2066a224d710648a88d8ad44273623a89ae0f4bb2645b00f0d0e1685c8ccedfd379259255957e653f3c3199621ac1d4c26098f538b6bfa7
-EBUILD pysam-0.21.0.ebuild 1744 BLAKE2B d6211a396810673da6392e4377a412bc6886c5eb9d5ad45ae85b278ae9d2202c4a706186b64ae3b1ae88fc0b32c532dad494bf69757b3c66dbf96e7001b48d2a SHA512 41be02962a1af5463dcc4ca98ec2af0e6986ec8d8a8101b813954754865c95d75f5f8a0ae20d3c76465475aa94e30fade45734931221eea01ab05cb7746acfce
+DIST pysam-0.22.1.gh.tar.gz 3885851 BLAKE2B 6f83c445c7e63e28823f443b0f106726303b0609f4040e9dca930c820d48c2adfe13d33ecffb514ce75c3b03968af050652689a0be39aaabca1af546e9188480 SHA512 fb8dc7c4a6ae908d8d409789f2706cce589d4b6a1057bcc4043f8a26a5b390f79d30d1a1cbe69cbf370caabf261ed8367685393240765080e94f1782ed7f0350
+EBUILD pysam-0.22.1.ebuild 1648 BLAKE2B 9d0c666e39b48dea088445a0959d364892f9b2a3e90664788f214ac66df709c70eaaf8c90240488a4c948409f0548641f4d511af983037b3afc481444621f7fb SHA512 e35adedadd3c3726eb817c85f225fc2715eccdcd0c2bed5c11f749d07a7e99b2f28fee0244bd64f1383329d20edb7a2364112483af8a814b447b29fc3d1b762b
EBUILD pysam-9999.ebuild 1709 BLAKE2B b7297d21abf0e581c5c2d8a72a7e6805cb5f96f6e878cc979fc0f5a34e57bdd25a2f50abaa9ee10040559e66ee42d3a24696a7093103658175b27858acaac95c SHA512 7e7a782243897a89a3539b3eb79ccd0790c6b0afcf79453526c30371f867faaf8eca6454e64d3bea250ff13753ff400fe5ff3352c080c85285cafa2346e3564a
MISC metadata.xml 442 BLAKE2B e3d339868a09d8930ff6d83f414f8166ed283a66d83d5b0fed0031024db151b17b1347f5e015f2b9c2152a041e2beb70696362be9b4e3fc225078bc5c520ad58 SHA512 4b1d08c5524e1bb04129e0d38f0584654b34979024afd2cf15bd482654ca8fac9c82e6db0661f7370f9fefa6949f1291ba3c18a9dca5d5041bd6f76554fa33c7
diff --git a/sci-biology/pysam/files/pysam-0.21.0-cython-3.patch b/sci-biology/pysam/files/pysam-0.21.0-cython-3.patch
deleted file mode 100644
index 303a4fb0dcdc..000000000000
--- a/sci-biology/pysam/files/pysam-0.21.0-cython-3.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 17bb13dcfdb56ac238458dcef23fe01893a892e9 Mon Sep 17 00:00:00 2001
-From: John Marshall <jmarshall@hey.com>
-Date: Sat, 8 Apr 2023 11:00:46 +1200
-Subject: [PATCH] Remove incorrect type annotation
-
-The annotation already in pysam/libcbcf.pyi is correct.
-Fixes #1179 as reopened on April 6th.
----
- pysam/libcbcf.pyx | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pysam/libcbcf.pyx b/pysam/libcbcf.pyx
-index 8c088af2..8ecfe5f3 100644
---- a/pysam/libcbcf.pyx
-+++ b/pysam/libcbcf.pyx
-@@ -3479,7 +3479,7 @@ cdef class VariantRecordSample(object):
- return bcf_format_get_alleles(self)
-
- @alleles.setter
-- def alleles(self, value: tuple):
-+ def alleles(self, value):
- # Sets the genotype, supply a tuple of alleles to set.
- # The supplied alleles need to be defined in the correspoding pysam.libcbcf.VariantRecord
- # The genotype is reset when an empty tuple, None or (None,) is supplied
diff --git a/sci-biology/pysam/pysam-0.21.0.ebuild b/sci-biology/pysam/pysam-0.22.1.ebuild
index 77292ed29613..9070476873e1 100644
--- a/sci-biology/pysam/pysam-0.21.0.ebuild
+++ b/sci-biology/pysam/pysam-0.22.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -17,30 +17,26 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="=sci-libs/htslib-1.17*:="
+RDEPEND="=sci-libs/htslib-1.20*:="
DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
test? (
- =sci-biology/bcftools-1.17*
- =sci-biology/samtools-1.17*
+ =sci-biology/bcftools-1.20*
+ =sci-biology/samtools-1.20*
)"
distutils_enable_tests pytest
DISTUTILS_IN_SOURCE_BUILD=1
-PATCHES=(
- # backport
- # https://github.com/pysam-developers/pysam/commit/17bb13dcfdb56ac238458dcef23fe01893a892e9
- "${FILESDIR}"/${P}-cython-3.patch
-)
-
EPYTEST_DESELECT=(
# only work with bundled htslib
'tests/tabix_test.py::TestRemoteFileHTTP'
'tests/tabix_test.py::TestRemoteFileHTTPWithHeader'
+
+ 'tests/AlignedSegment_test.py::TestBaseModifications'
)
python_prepare_all() {