summaryrefslogtreecommitdiff
path: root/sci-biology/psipred/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/psipred/files')
-rw-r--r--sci-biology/psipred/files/3.1-Makefile.patch38
-rw-r--r--sci-biology/psipred/files/3.1-path.patch38
-rw-r--r--sci-biology/psipred/files/3.2-fgets.patch13
3 files changed, 0 insertions, 89 deletions
diff --git a/sci-biology/psipred/files/3.1-Makefile.patch b/sci-biology/psipred/files/3.1-Makefile.patch
deleted file mode 100644
index 0c70b6868565..000000000000
--- a/sci-biology/psipred/files/3.1-Makefile.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/src/Makefile b/src/Makefile
-index abed8af..26061fa 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -6,9 +6,9 @@
- #### CFLAGS Flags to pass to C compiler.
-
- INCDIR = .
--CC = cc
-+CC ?= gcc
-
--CFLAGS = -O
-+CFLAGS ?= -O2
- LIBS = -lm
-
- all: psipred psipass2 chkparse seq2mtx pfilt
-@@ -20,16 +20,16 @@ clean:
- /bin/rm -f psipred psipass2 chkparse seq2mtx pfilt
-
- psipred: sspred_avpred.c ssdefs.h sspred_net.h
-- $(CC) $(CFLAGS) sspred_avpred.c $(LIBS) -o psipred
-+ $(CC) $(CFLAGS) $(LDFLAGS) sspred_avpred.c $(LIBS) -o psipred
-
- psipass2: sspred_hmulti.c ssdefs.h sspred_net2.h
-- $(CC) $(CFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
-+ $(CC) $(CFLAGS) $(LDFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
-
- chkparse: chkparse.c
-- $(CC) $(CFLAGS) chkparse.c $(LIBS) -o chkparse
-+ $(CC) $(CFLAGS) $(LDFLAGS) chkparse.c $(LIBS) -o chkparse
-
- seq2mtx: seq2mtx.c
-- $(CC) $(CFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
-+ $(CC) $(CFLAGS) $(LDFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
-
- pfilt: pfilt.c
-- $(CC) $(CFLAGS) pfilt.c $(LIBS) -o pfilt
-+ $(CC) $(CFLAGS) $(LDFLAGS) pfilt.c $(LIBS) -o pfilt
diff --git a/sci-biology/psipred/files/3.1-path.patch b/sci-biology/psipred/files/3.1-path.patch
deleted file mode 100644
index 564e9c8a1ef9..000000000000
--- a/sci-biology/psipred/files/3.1-path.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/runpsipred b/runpsipred
-index 4ccf44e..34dee99 100755
---- a/runpsipred
-+++ b/runpsipred
-@@ -14,13 +14,13 @@
- set dbname = uniref90filt
-
- # Where the NCBI programs have been installed
--set ncbidir = /usr/local/bin
-+set ncbidir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
-
- # Where the PSIPRED V2 programs have been installed
--set execdir = ./bin
-+set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
-
- # Where the PSIPRED V2 data files have been installed
--set datadir = ./data
-+set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
-
- set basename = $1:r
- set rootname = $basename:t
-diff --git a/runpsipred_single b/runpsipred_single
-index 1f7680b..7bd5bc3 100755
---- a/runpsipred_single
-+++ b/runpsipred_single
-@@ -10,10 +10,10 @@
- # NOTE: Script modified to be more cluster friendly (DTJ April 2008)
-
- # Where the PSIPRED V3 programs have been installed
--set execdir = ./bin
-+set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
-
- # Where the PSIPRED V3 data files have been installed
--set datadir = ./data
-+set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
-
- set basename = $1:r
- set rootname = $basename:t
diff --git a/sci-biology/psipred/files/3.2-fgets.patch b/sci-biology/psipred/files/3.2-fgets.patch
deleted file mode 100644
index ec06d141ee34..000000000000
--- a/sci-biology/psipred/files/3.2-fgets.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/sspred_avpred.c b/src/sspred_avpred.c
-index 37b1332..4f04ab6 100644
---- a/src/sspred_avpred.c
-+++ b/src/sspred_avpred.c
-@@ -223,7 +223,7 @@ predict(int argc, char **argv)
- int getmtx(FILE *lfil)
- {
- int aa, i, j, naa;
-- char buf[256], *p;
-+ char buf[65536], *p;
-
- if (fscanf(lfil, "%d", &naa) != 1)
- fail("Bad mtx file - no sequence length!");