summaryrefslogtreecommitdiff
path: root/sci-biology/fasttree/files/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/fasttree/files/CMakeLists.txt')
-rw-r--r--sci-biology/fasttree/files/CMakeLists.txt25
1 files changed, 13 insertions, 12 deletions
diff --git a/sci-biology/fasttree/files/CMakeLists.txt b/sci-biology/fasttree/files/CMakeLists.txt
index e7c53afdaf36..c52b90cc7be2 100644
--- a/sci-biology/fasttree/files/CMakeLists.txt
+++ b/sci-biology/fasttree/files/CMakeLists.txt
@@ -1,23 +1,24 @@
-cmake_minimum_required (VERSION 2.6)
+cmake_minimum_required (VERSION 2.8.12)
project(fasttree C)
+include(GNUInstallDirs)
+
option(USE_OPENMP "Use OpenMP to parallelize many of the steps in computing a tree" ON)
-option(USE_DOUBLE "Use double precission" OFF)
+option(USE_DOUBLE "Use double precision" OFF)
option(HAS_SSE3 "Use SSE2/SSE3 instructions to speed up some inner loops" ON)
if(USE_OPENMP)
- SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DOPENMP -fopenmp" )
- SET( CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -DOPENMP -fopenmp" )
-endif(USE_OPENMP)
+ set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DOPENMP -fopenmp" )
+ set( CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -DOPENMP -fopenmp" )
+endif()
if(USE_DOUBLE)
- SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DUSE_DOUBLE" )
-endif(USE_DOUBLE)
+ set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DUSE_DOUBLE" )
+endif()
if(NOT HAS_SSE3)
- SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNO_SSE" )
-endif(NOT HAS_SSE3)
-
+ set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNO_SSE" )
+endif()
add_executable(FastTree FastTree-${VERSION}.c)
add_executable(FastTreeUPGMA FastTreeUPGMA-${VERSION}.c)
@@ -25,6 +26,6 @@ add_executable(FastTreeUPGMA FastTreeUPGMA-${VERSION}.c)
target_link_libraries(FastTree m)
target_link_libraries(FastTreeUPGMA m)
-install (TARGETS FastTree FastTreeUPGMA DESTINATION bin)
+install (TARGETS FastTree FastTreeUPGMA DESTINATION ${CMAKE_INSTALL_BINDIR})
-install(FILES MOTree.pm CompareTree.pl CompareToBootstrap.pl DESTINATION share/fasttree)
+install(FILES MOTree.pm CompareTree.pl CompareToBootstrap.pl DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/fasttree)