summaryrefslogtreecommitdiff
path: root/sci-astronomy/swarp/swarp-2.41.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/swarp/swarp-2.41.5.ebuild')
-rw-r--r--sci-astronomy/swarp/swarp-2.41.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-astronomy/swarp/swarp-2.41.5.ebuild b/sci-astronomy/swarp/swarp-2.41.5.ebuild
new file mode 100644
index 000000000000..ef3fa14ef8e2
--- /dev/null
+++ b/sci-astronomy/swarp/swarp-2.41.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Resample and coadd astronomical FITS images"
+HOMEPAGE="http://www.astromatic.net/software/swarp"
+SRC_URI="https://github.com/astromatic/swarp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cfitsio doc threads"
+
+RDEPEND="cfitsio? ( sci-libs/cfitsio )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with cfitsio) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/.
+}