summaryrefslogtreecommitdiff
path: root/sci-astronomy/stiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/stiff')
-rw-r--r--sci-astronomy/stiff/Manifest2
-rw-r--r--sci-astronomy/stiff/stiff-2.4.0.ebuild14
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-astronomy/stiff/Manifest b/sci-astronomy/stiff/Manifest
index 1cc9fcf69452..4fa664e2fba3 100644
--- a/sci-astronomy/stiff/Manifest
+++ b/sci-astronomy/stiff/Manifest
@@ -1,3 +1,3 @@
DIST stiff-2.4.0.tar.gz 1074161 BLAKE2B 50a865985184b1b5cbd78024ed3ee72fa6d19431dbe99336d1ad671eaf076a5aa94471a11d447e3981881c789c00167b89c3fa92262f48f03f8a4251fa8cce3f SHA512 c8a293a2d1771b21d8af1194f9a2f582eca1a363964e76b78319c9cc2407332ef5e31dc74c0d10b9d5c7b6ae18ebd35ee59c53ad31c5f3966fabcd03948cadf6
-EBUILD stiff-2.4.0.ebuild 748 BLAKE2B 1d5858be5dcc2d17f889c09f339fb9506f9795969055dee17bbcaa480cccb69fd5e647fb2f8429803bd4e856268d7f0007be016ee877f73ef02c94d35d336fe9 SHA512 b3abfa46dcb8a73d2ff4b7c0966f6df5d5d798b7bf78a2b8ad369900dca9157c1f53060fa663309b18564bdc153e9ca4a035617811108dc3b050f2134fc83f24
+EBUILD stiff-2.4.0.ebuild 865 BLAKE2B a4627caf440e512b1e455b66e1697b8a39f55d0aba9add1b13e34bc47934c688ea71fe9a5d59598182f2aecbcf871c6336d501898663f54ccd104a15add8b900 SHA512 784820696e586935fd74270b8d7b77ae5f8a6aa708fce9d1cfc6ea675a754380d8cfdde266925daab1ce6f830f1bb25aae8d45f2cdde30000fc3df0ea10c621c
MISC metadata.xml 465 BLAKE2B 09afaab47c9bffec55573bbbeecadce07f4e25f0e7010c261815479670e2484731420d9a6e6bce4463a4dc4e2ec73b1d36439b974537ce1aa75053b83638a0dd SHA512 651824579acd42807a5033d63b3803af2fa0d97f7742df3bf44d657bced9eeab5e89dcff1182cd3257c9815a1b44167df5326977f52b21a25b6e8cd6e1c4eafc
diff --git a/sci-astronomy/stiff/stiff-2.4.0.ebuild b/sci-astronomy/stiff/stiff-2.4.0.ebuild
index 5d5e1701b58f..85bdc78a39f9 100644
--- a/sci-astronomy/stiff/stiff-2.4.0.ebuild
+++ b/sci-astronomy/stiff/stiff-2.4.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} == "9999" ]] ; then
inherit subversion
ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
else
+ inherit flag-o-matic
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
@@ -25,8 +25,16 @@ RDEPEND="
sys-libs/zlib:0="
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+
+ # bug #708382
+ append-cflags -fcommon
+}
+
src_configure() {
- ECONF_SOURCE="${S}" econf $(use_enable threads)
+ CONFIG_SHELL="${EPREFIX}/bin/bash" ECONF_SOURCE="${S}" econf \
+ $(use_enable threads)
}
src_install() {