summaryrefslogtreecommitdiff
path: root/sci-astronomy/stellarium/files/stellarium-0.23.4-unbundle-zlib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/stellarium/files/stellarium-0.23.4-unbundle-zlib.patch')
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.23.4-unbundle-zlib.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-astronomy/stellarium/files/stellarium-0.23.4-unbundle-zlib.patch b/sci-astronomy/stellarium/files/stellarium-0.23.4-unbundle-zlib.patch
new file mode 100644
index 000000000000..077b1b5710a6
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-0.23.4-unbundle-zlib.patch
@@ -0,0 +1,23 @@
+This patch is not really needed, because zlib is already used from system, but
+it makes it easier to ensure that nothing else is bundled
+
+diff --git a/src/external/CMakeLists.txt b/src/external/CMakeLists.txt
+index e5af410..6d7bf6b 100644
+--- a/src/external/CMakeLists.txt
++++ b/src/external/CMakeLists.txt
+@@ -36,6 +36,7 @@ target_link_libraries(glues_stel Qt${QT_VERSION_MAJOR}::Gui)
+ set_target_properties(glues_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(glues_stel PROPERTIES FOLDER "src/external")
+
++if(0)
+ SET(zlib_SRCS
+ zlib/adler32.c
+ zlib/compress.c
+@@ -69,6 +70,7 @@ target_include_directories(zlib_stel PUBLIC zlib)
+ #turn off automoc, not needed here
+ set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
++endif()
+
+ ################################# INDI ################################
+ IF(USE_PLUGIN_TELESCOPECONTROL)