summaryrefslogtreecommitdiff
path: root/sci-astronomy/scamp
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/scamp')
-rw-r--r--sci-astronomy/scamp/Manifest2
-rw-r--r--sci-astronomy/scamp/scamp-2.13.1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/scamp/Manifest b/sci-astronomy/scamp/Manifest
index 5734b5084b91..9fa51525f0ff 100644
--- a/sci-astronomy/scamp/Manifest
+++ b/sci-astronomy/scamp/Manifest
@@ -1,4 +1,6 @@
AUX scamp-2.10.0-spread_bits64.patch 510 BLAKE2B b5215c79a6e13d3393f119f661a51cca8ec9afe43c112e12a6c4c44eebd9a165e6b180ef709811099c492fc7a77c418a9b3dd592b458fbff77c0c8b9e091fc45 SHA512 e2416122dbdf33c1b33c9e02f3e27cc257379d52962cb65ae9758dc08f8f506c55d6925e8819ce4ad9530dab8795797f61c1023842556e55d30d9dc8c8798caf
DIST scamp-2.10.0.tar.gz 56354286 BLAKE2B b31d292413160f85f8086d848d81f36adde3bc560c737adfe77245d23eb6eab19e5f73a343669b462453542a140d89fb3d12b5d6a481949205722c6e2f5234cd SHA512 7c7a4ab167a3c03b7fd862f39ccd9368d6ac31270a86b336f1ee2a52f8e4324e29e6324047416159c0b73bb54b05f12b7b70c2de3cb4197999cb848fc5ce4c0d
+DIST scamp-2.13.1.tar.gz 56345223 BLAKE2B 0f9c5693c22175ec9706eae8117a00acc24684fa389084b13772c3dff46ad10a1a9a43c1bad0fd05619e323dfa461a7e23c14a597d68fa7f488c6eb33a3536b6 SHA512 d5d28a2ba1c0ce20f6011ae757804e82fb30b666f3c34a9a6307653f7477f848d507be4df437c219427894680815c142b8653e74a5a64497dc7919d16d126a49
EBUILD scamp-2.10.0.ebuild 1080 BLAKE2B 97e6d7908876781e7965db5a322b51ce10f97698ddc0610ae4f28e7f1b14db31beced8652a0a32a7d771cf66e13fd9cdd0f4b4ba998078784360e79f082e4666 SHA512 e9926c55ee6c3e42edb8d3a34466a147ff3483562306dce096bf4309b9355764e6091c3d0a65c0d7bbaa10c8065dc8311e2648bac95f19a876f1833b79b47ed2
+EBUILD scamp-2.13.1.ebuild 1080 BLAKE2B 32f381852c421ad7065dfbbb379df725ea8043633d5d73c238c17fb7a285478997e26c8ab1a89cb9aa12160443fbe70e9c37f32d99551c95f4eaf52292bf42dc SHA512 80cd5e9d36ca46908becd2a496f7241c4fe9b0843ab55a97575295db39973c969d85078f82a6173456e66484e8cbf16dfdebba7e995d09efdf3ea2d151357a53
MISC metadata.xml 968 BLAKE2B 6b1b4f89766c740c93f2f058dc210b9e50c71f57bdc536d7fa3e7674c3b050358c348acbb0c96ebceeb1803b96cd815bef69b3f6ecd697d837706dcba59d6d74 SHA512 aa606c3f3d96e3ffa5aa006ed4a48c0f14c493e225b5aff4553aaca6975336b892a243f73b3b0f83ad2962d849e551292a99e4e4d21ba4c3c2733abcc3eda736
diff --git a/sci-astronomy/scamp/scamp-2.13.1.ebuild b/sci-astronomy/scamp/scamp-2.13.1.ebuild
new file mode 100644
index 000000000000..13b2f01fe1a0
--- /dev/null
+++ b/sci-astronomy/scamp/scamp-2.13.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Astrometric and photometric solutions for astronomical images"
+HOMEPAGE="http://www.astromatic.net/software/scamp https://github.com/astromatic/scamp"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/astromatic/${PN}.git"
+else
+ SRC_URI="https://github.com/astromatic/scamp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="plplot threads"
+
+RDEPEND="
+ sci-astronomy/cdsclient
+ sci-libs/atlas[lapack,threads=]
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10.0-spread_bits64.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -e "s/lapack_atlas/atlclapack/g" -i m4/acx_atlas.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas"
+ $(use_enable plplot)
+ $(use_enable threads)
+ )
+
+ econf "${myeconfargs[@]}"
+}