summaryrefslogtreecommitdiff
path: root/ros-meta/ament_cmake/ament_cmake-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'ros-meta/ament_cmake/ament_cmake-9999.ebuild')
-rw-r--r--ros-meta/ament_cmake/ament_cmake-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/ros-meta/ament_cmake/ament_cmake-9999.ebuild b/ros-meta/ament_cmake/ament_cmake-9999.ebuild
index f6fdfb5d439e..960565dee0ad 100644
--- a/ros-meta/ament_cmake/ament_cmake-9999.ebuild
+++ b/ros-meta/ament_cmake/ament_cmake-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-r1
+inherit cmake python-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -38,6 +38,7 @@ DEPEND="
dev-ros/ament_cmake_export_interfaces
dev-ros/ament_cmake_export_libraries
dev-ros/ament_cmake_export_link_flags
+ dev-ros/ament_cmake_export_targets
dev-ros/ament_cmake_libraries
dev-ros/ament_cmake_python
dev-ros/ament_cmake_target_dependencies
@@ -54,10 +55,6 @@ BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
+ python_setup
+ cmake_src_configure
}