summaryrefslogtreecommitdiff
path: root/net-wireless/soapyhackrf/soapyhackrf-0.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/soapyhackrf/soapyhackrf-0.3.4.ebuild')
-rw-r--r--net-wireless/soapyhackrf/soapyhackrf-0.3.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-wireless/soapyhackrf/soapyhackrf-0.3.4.ebuild b/net-wireless/soapyhackrf/soapyhackrf-0.3.4.ebuild
new file mode 100644
index 000000000000..017475da18d7
--- /dev/null
+++ b/net-wireless/soapyhackrf/soapyhackrf-0.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="SoapySDR HackRF module"
+HOMEPAGE="https://github.com/pothosware/SoapyHackRF"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyHackRF.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyHackRF/archive/soapy-hackrf-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyHackRF-soapy-hackrf-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr:=
+ net-libs/libhackrf:="
+DEPEND="${RDEPEND}"