summaryrefslogtreecommitdiff
path: root/net-wireless/qdmr/qdmr-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/qdmr/qdmr-0.8.1.ebuild')
-rw-r--r--net-wireless/qdmr/qdmr-0.8.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/net-wireless/qdmr/qdmr-0.8.1.ebuild b/net-wireless/qdmr/qdmr-0.8.1.ebuild
deleted file mode 100644
index c17d694d921a..000000000000
--- a/net-wireless/qdmr/qdmr-0.8.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake udev linux-info
-
-DESCRIPTION="GUI application for configuring and programming cheap DMR radios"
-HOMEPAGE="https://dm3mat.darc.de/qdmr/"
-if [ "${PV}" = "9999" ]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hmatuschek/qdmr.git"
-else
- SRC_URI="https://github.com/hmatuschek/qdmr/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-RDEPEND="
- dev-qt/designer:5
- dev-qt/qttest:5
- dev-qt/qtwidgets:5
- dev-qt/qtgui:5
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5
- dev-qt/qtpositioning:5
- dev-qt/qtserialport:5
- virtual/libusb:1
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5"
-BDEPEND=""
-
-pkg_setup() {
- CONFIG_CHECK="~USB_ACM"
- WARNING_USB_ACM="Some radios require CONFIG_USB_ACM to work, you may need to enable this driver to talk to your radio"
- CONFIG_CHECK="~USB_SERIAL"
- WARNING_USB_SERIAL="Some radios require CONFIG_USB_SERIAL to work, you may need to enable this driver to talk to your radio"
- check_extra_config
-}
-
-src_prepare() {
- #no devil perms
- sed -i 's#666#660#' dist/99-qdmr.rules
- sed -i "s#/etc/udev/rules.d/#$(get_udevdir)/rules.d#" lib/CMakeLists.txt
- cmake_src_prepare
-}