summaryrefslogtreecommitdiff
path: root/net-wireless/kismet/kismet-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/kismet/kismet-9999.ebuild')
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 84a92eaf262c..8109bb0b1b4f 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..12} )
-inherit autotools python-single-r1 udev systemd
+inherit autotools flag-o-matic python-single-r1 udev systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
@@ -38,8 +38,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
CDEPEND="
${PYTHON_DEPS}
- acct-user/kismet
- acct-group/kismet
mqtt? ( app-misc/mosquitto )
networkmanager? ( net-misc/networkmanager )
dev-libs/glib:2
@@ -65,6 +63,8 @@ CDEPEND="
ubertooth? ( net-wireless/ubertooth )
"
RDEPEND="${CDEPEND}
+ acct-user/kismet
+ acct-group/kismet
$(python_gen_cond_dep '
dev-python/pyserial[${PYTHON_USEDEP}]
')
@@ -112,6 +112,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/877761
+ # https://github.com/kismetwireless/kismet/issues/518
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf \
$(use_enable libusb libusb) \
$(use_enable libusb wifi-coconut) \