summaryrefslogtreecommitdiff
path: root/net-wireless/gr-osmosdr/files/gr-osmosdr-0.2.3_p20210128-fix-enable-python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-osmosdr/files/gr-osmosdr-0.2.3_p20210128-fix-enable-python.patch')
-rw-r--r--net-wireless/gr-osmosdr/files/gr-osmosdr-0.2.3_p20210128-fix-enable-python.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/net-wireless/gr-osmosdr/files/gr-osmosdr-0.2.3_p20210128-fix-enable-python.patch b/net-wireless/gr-osmosdr/files/gr-osmosdr-0.2.3_p20210128-fix-enable-python.patch
new file mode 100644
index 000000000000..2bf79b1fe20e
--- /dev/null
+++ b/net-wireless/gr-osmosdr/files/gr-osmosdr-0.2.3_p20210128-fix-enable-python.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 96a2c90..a3836f8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -187,9 +187,7 @@ find_package(Doxygen)
+
+ # Python
+ ##########
+-
+-find_package(PythonLibs 3)
+-find_package(pybind11)
++include(GrPybind)
+
+ GR_REGISTER_COMPONENT("Python support" ENABLE_PYTHON
+ PYTHONLIBS_FOUND