summaryrefslogtreecommitdiff
path: root/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild')
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
new file mode 100644
index 000000000000..716aaa6176fc
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8})
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/osmocom/gr-iqbal.git"
+else
+ SRC_URI="https://github.com/osmocom/gr-iqbal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN="$(usex doc)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize "${ED}/$(python_get_sitedir)"
+}