summaryrefslogtreecommitdiff
path: root/net-wireless/gnome-bluetooth
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest2
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 6e5f06cf16ff..045d5d7c11f3 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1,4 +1,6 @@
AUX 61-gnome-bluetooth.rules 399 BLAKE2B ba3dd9fdc3834ce6a3460d8abff179d08c1258f7ba43e2350ed2c7e88aaf6fef4b06c51b6212650523c4de577cb3a85946bae9b955cf6c17a0c984431abd5d2b SHA512 74fd95e2afb3d3f13df72bb593ae6644a3a4975e43f5f50c622f14f756861596ef92aa331200d9fce6ff3976e8a1ed57e4053186b7a9716039ace971a6dfed0d
DIST gnome-bluetooth-3.28.2.tar.xz 349456 BLAKE2B 24a8adbbd37a6a7338a10bb84fd113c3a65bb9c5ef277c9df082f10f52b9d9dc2bc3ff6182993fd85fb5f5f8269a965f0aba864f73ed8595a700a51e59242fc1 SHA512 03f66f8c5c195b10cf2c13dc93191b9f2f79adae099ddb8037ef1277731f37b8f0a42b603e8aacbe2fb108be6abf7a77a823d86d5fac62a42a53e3498d53d87e
+DIST gnome-bluetooth-3.34.0.tar.xz 351232 BLAKE2B 5ed3a2edc4d0a494013c246ce4caa64cc343c08ceeca3fbdc809591c59a59a7e269b35ba2474f38bb9ae1aba7f7b47f2d164c2be49d3e59d1af538a77a7451ab SHA512 25c99f3ac4398b24c08018cdf41a124c94312bc0b1c7202c82918134ddbdea16d6ee0980536cb45deb42ae8fa25b6e86ad21870646235108583831bf5f00926e
EBUILD gnome-bluetooth-3.28.2.ebuild 1422 BLAKE2B 3cc1a98ac82cecaeb19a6ccafcff223da18b52187295d8122b185942146f10cc59fc91af72278f8ed33d2411f576dcdccb821a95e16d299ddd9b7b6109fe2d5a SHA512 0899e136be0a00ccb890ce076426bfbb5689cccdada82e1831b851a8cc09ff1b191db3e94031a3eaacf5eb1940d37c7165499cdbcfefff48d9506c81c5ce7c6d
+EBUILD gnome-bluetooth-3.34.0.ebuild 1419 BLAKE2B e309219d66d5ee86bdb163be7fcd755193b33a27ea9321ba1c8d236fce74c11f3edc4c9f286737748143a0f48465a1cc50d74136930b421e10407ec6ec469fb4 SHA512 8d6e506138a641bb92f780649a1804d8744918accc8ea425952f0b3e9eb5ac36a32b0b405a9d83ef8967f7e849a3515d62a8effd171b6f5811d6b69f06a1d74d
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.0.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.0.ebuild
new file mode 100644
index 000000000000..0eb1a3234d3f
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson udev xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="gtk-doc +introspection"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/plugdev
+ virtual/udev
+ >=net-wireless/bluez-5
+"
+BDEPEND="
+ >=dev-util/meson-0.49.0
+ !net-wireless/bluez-gnome
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicon_update=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! has_version 'sys-auth/consolekit[acl]' && ! has_version 'sys-apps/systemd[acl]' ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}