summaryrefslogtreecommitdiff
path: root/net-proxy
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/Manifest.gzbin5372 -> 5375 bytes
-rw-r--r--net-proxy/tinyproxy/Manifest2
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.11.2.ebuild74
3 files changed, 76 insertions, 0 deletions
diff --git a/net-proxy/Manifest.gz b/net-proxy/Manifest.gz
index 24bd2bb7055c..4d0fe9908e17 100644
--- a/net-proxy/Manifest.gz
+++ b/net-proxy/Manifest.gz
Binary files differ
diff --git a/net-proxy/tinyproxy/Manifest b/net-proxy/tinyproxy/Manifest
index ba291b443b86..bb3a1560c9e7 100644
--- a/net-proxy/tinyproxy/Manifest
+++ b/net-proxy/tinyproxy/Manifest
@@ -1,6 +1,8 @@
AUX tinyproxy-1.10.0.initd 855 BLAKE2B 4bd9a260a930958ea449a08edce1f9e8633429a5222a3ea7254b4bdc03808c5f9f87d9b33556f345e305d28e155834b33ff2a952c041af582cae3bedbae2034d SHA512 cd440ed686e8128ed46441ca29da8376c4d28e9e34ae9b85c18eb2f1681d60c0c04b79401a7368f917eeab6768965d6c867d0ac6578a7858557c11b356446c02
AUX tinyproxy-1.10.0.service 181 BLAKE2B 1e5c14f607d0c54d215a6ffe5656bac288e48ca809aca67b658bb13917869e5203d66730f52670fb9030dd9f6cf249d09f357bbdd143436f6b358377d8f78036 SHA512 7721b986326f82b03d79983be33047fdf4b37b5c63992645a321bf8bd3edea63680a2bf81b2d51fbeab2a5884773a0598dba14f9d597d3db0eea7c7f6b4c79d3
AUX tinyproxy.tmpfiles.conf 44 BLAKE2B a4e1cf0c8cbd78360175b8260c7d83885dfc9560a78faa6fc111f8611b6dd43c3cbf9fa62e60f8333cac4d0bededbe048c626d8a85d4f3c6c1bfa1ae249c599e SHA512 59d1efcc996e94ae684708ef06263c61f17680a776938a90ce145cf6f0243ed253d402cd886dab7c2c287f47dbc6f02f0e34904433e7b6756cfaa18a1b766b4e
+DIST tinyproxy-1.11.2.tar.xz 185864 BLAKE2B ae8f1cc0fcfa3f2a6b239ad1f0f34bf21843cbf85613643b221359904e672d5c28c69bcb6b61f0244c5a3e6fd901b0c24488c3b80a0aa1f95b87ff90b175dc62 SHA512 008e43b770f946965d5a3fbad1881859e30b66a3a4a97cf9982e63d81139da7a8f23937601b72f32276166cd170008cafec9231b616fc840f05cae3c1329be35
DIST tinyproxy-31339cb1615765f2fbb4ec7779400535bad6da46.tar.gz 112886 BLAKE2B 82af9f671b31c9be46624400d726e428837763ab763942c335df1aa63499e33c17384b55ea2f68790cd3b8b1e4eff3b61b40f25e1d55506ce0f0694c7cddaddb SHA512 638ae0731aa2d9f498643aa883871f7b3978c68ee5098fcbeb234234e5432d1a833c33fb0cc1944504369bdf975baa0bd6166664c340825b9b55664d8afdf94c
EBUILD tinyproxy-1.11.1_p20230201.ebuild 1830 BLAKE2B 826404cdd80e376f217747a5166f8c3a684112a4e5857aa3b85f1478d5e85d1995fb817be206663172a5cf56d5db051bece2430fb04c949a3d069604f6a71d68 SHA512 87a32d424ee2727b56790ca11a73d6ca7da6b77ff40119ddd3da99312319e553c608c1e1d5631c9efda9a0c571d389d6bc36266df66e0358de10df4d991f81c4
+EBUILD tinyproxy-1.11.2.ebuild 1720 BLAKE2B 7d7128afbc40356358351f631a502cd63458769914b016f9fced5a723c2f882b633a24cd42030d2876f7e6a34e93862c42edcaf1a6d3ad11172000063a8c8d4a SHA512 6c3b99cabe706f36651f970fc95502f19bd2fbb3a54fa936c4f05ef134663b35729de32b6864b33a3c8fd8478e1b608a74151ee65faf957f37e81ad888931907
MISC metadata.xml 718 BLAKE2B 3afc0958e86832552618442ab17be839a9cdab7a16b09c6c818c40aba1dfa7ac5d38030295b9377241a60c363263a7b1dd95b710fcf1ff4cb3bd8ed570779ff7 SHA512 dee3edacaa08d3d006e6b762a23859bb0d903a13fa386512f2117093c761073fdded8b04a172e41993525d1baefb3e46fe90f3cb950149c6a2409d84386950c1
diff --git a/net-proxy/tinyproxy/tinyproxy-1.11.2.ebuild b/net-proxy/tinyproxy/tinyproxy-1.11.2.ebuild
new file mode 100644
index 000000000000..4cbde7982d63
--- /dev/null
+++ b/net-proxy/tinyproxy/tinyproxy-1.11.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd tmpfiles
+
+DESCRIPTION="A lightweight HTTP/SSL proxy"
+HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
+SRC_URI="https://github.com/tinyproxy/tinyproxy/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="test debug +filter-proxy reverse-proxy transparent-proxy
++upstream-proxy +xtinyproxy-header"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( xtinyproxy-header )"
+
+DEPEND="
+ acct-group/tinyproxy
+ acct-user/tinyproxy
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|nobody|${PN}|g" \
+ etc/${PN}.conf.in || die "sed failed"
+
+ sed -i -e "s# -Wp,-D_FORTIFY_SOURCE=2##" configure.ac || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable filter-proxy filter) \
+ $(use_enable reverse-proxy reverse) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable upstream-proxy upstream) \
+ $(use_enable xtinyproxy-header xtinyproxy) \
+ --localstatedir=/var
+}
+
+src_test() {
+ # The make check target does not run the test suite
+ emake test
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS README.md
+
+ diropts -m0775 -o ${PN} -g ${PN}
+ keepdir /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.10.0.initd tinyproxy
+ systemd_newunit "${FILESDIR}"/${PN}-1.10.0.service tinyproxy.service
+ dotmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog "For filtering domains and URLs, enable filter option in the configuration"
+ elog "file and add them to the filter file (one domain or URL per line)."
+}