summaryrefslogtreecommitdiff
path: root/net-proxy/haproxy/haproxy-2.7.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/haproxy/haproxy-2.7.9999.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-2.7.9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-proxy/haproxy/haproxy-2.7.9999.ebuild b/net-proxy/haproxy/haproxy-2.7.9999.ebuild
index fd42fd4cb085..7c18e82dbedb 100644
--- a/net-proxy/haproxy/haproxy-2.7.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.7.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -70,12 +70,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )