summaryrefslogtreecommitdiff
path: root/net-proxy/3proxy/files/3proxy-0.9.4-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/3proxy/files/3proxy-0.9.4-gentoo.patch')
-rw-r--r--net-proxy/3proxy/files/3proxy-0.9.4-gentoo.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-proxy/3proxy/files/3proxy-0.9.4-gentoo.patch b/net-proxy/3proxy/files/3proxy-0.9.4-gentoo.patch
new file mode 100644
index 000000000000..57a9b479f1e3
--- /dev/null
+++ b/net-proxy/3proxy/files/3proxy-0.9.4-gentoo.patch
@@ -0,0 +1,38 @@
+diff --git a/Makefile.Linux b/Makefile.Linux
+index 4f3f2b3..f15f6ff 100644
+--- a/Makefile.Linux
++++ b/Makefile.Linux
+@@ -8,13 +8,13 @@
+ # library support. Add -DSAFESQL for poorely written ODBC library / drivers.
+
+ BUILDDIR = ../bin/
+-CC = gcc
++CC ?= gcc
+
+-CFLAGS = -g -fPIC -O2 -fno-strict-aliasing -c -pthread -DWITHSPLICE -D_GNU_SOURCE -DGETHOSTBYNAME_R -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL -DWITH_NETFILTER
++CFLAGS += -fPIC -fno-strict-aliasing -c -pthread -DWITHSPLICE -D_GNU_SOURCE -DGETHOSTBYNAME_R -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL -DWITH_NETFILTER
+ COUT = -o
+ LN = $(CC)
+ DCFLAGS =
+-LDFLAGS = -fPIE -O2 -fno-strict-aliasing -pthread
++LDFLAGS += -fPIE -fno-strict-aliasing -pthread
+ DLFLAGS = -shared
+ DLSUFFICS = .ld.so
+ # -lpthreads may be reuqired on some platforms instead of -pthreads
+@@ -40,13 +40,13 @@ PLUGINS = StringsPlugin TrafficPlugin PCREPlugin TransparentPlugin
+ include Makefile.inc
+
+ allplugins:
+- @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; make ; cd ../.. ; done
++ @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; $(MAKE) ; cd ../.. ; done
+
+ DESTDIR =
+ prefix =
+ exec_prefix = $(prefix)
+-man_prefix = /usr/share
+-chroot_prefix = /usr/local
++man_prefix = $(prefix)/usr/share
++chroot_prefix = $(prefix)/usr/local
+
+ INSTALL = /usr/bin/install
+ INSTALL_BIN = $(INSTALL) -m 755