summaryrefslogtreecommitdiff
path: root/net-print/sshlpr/sshlpr-1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/sshlpr/sshlpr-1-r1.ebuild')
-rw-r--r--net-print/sshlpr/sshlpr-1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-print/sshlpr/sshlpr-1-r1.ebuild b/net-print/sshlpr/sshlpr-1-r1.ebuild
new file mode 100644
index 000000000000..99cf50d6b50f
--- /dev/null
+++ b/net-print/sshlpr/sshlpr-1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ssh-lpr backend for cups -- print to remote systems over ssh"
+HOMEPAGE="http://www.masella.name/technical/sshlpr.html"
+SRC_URI="https://dev.gentoo.org/~radhermit/distfiles/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}
+ sys-apps/shadow
+ virtual/openssh"
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto $(cups-config --serverbin)/backend
+ exeopts -m0700
+ doexe ${PN}
+}