summaryrefslogtreecommitdiff
path: root/net-print/hplip/hplip-3.21.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/hplip/hplip-3.21.6.ebuild')
-rw-r--r--net-print/hplip/hplip-3.21.6.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-print/hplip/hplip-3.21.6.ebuild b/net-print/hplip/hplip-3.21.6.ebuild
index 84ae3994756d..e3f7c820026e 100644
--- a/net-print/hplip/hplip-3.21.6.ebuild
+++ b/net-print/hplip/hplip-3.21.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="threads(+),xml"
# 14 and 15 spit out a lot of warnings about subdirs
@@ -51,19 +51,19 @@ RDEPEND="
${COMMON_DEPEND}
app-text/ghostscript-gpl
!minimal? (
- $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' 'python3*')
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' 'python3*')
kernel_linux? ( virtual/udev )
$(python_gen_cond_dep '
- >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
- dev-python/distro[${PYTHON_MULTI_USEDEP}]
- fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ fax? ( dev-python/reportlab[${PYTHON_USEDEP}] )
qt5? (
- >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
- libnotify? ( dev-python/notify2[${PYTHON_MULTI_USEDEP}] )
+ >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_USEDEP}]
+ libnotify? ( dev-python/notify2[${PYTHON_USEDEP}] )
)
scanner? (
- >=dev-python/reportlab-3.2[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pillow-3.1.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/reportlab-3.2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_USEDEP}]
X? (
|| (
kde? ( kde-misc/skanlite )