summaryrefslogtreecommitdiff
path: root/net-print/cups/files/cups-2.3.3-no-libtool.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/cups/files/cups-2.3.3-no-libtool.patch')
-rw-r--r--net-print/cups/files/cups-2.3.3-no-libtool.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-print/cups/files/cups-2.3.3-no-libtool.patch b/net-print/cups/files/cups-2.3.3-no-libtool.patch
new file mode 100644
index 000000000000..cf8911294183
--- /dev/null
+++ b/net-print/cups/files/cups-2.3.3-no-libtool.patch
@@ -0,0 +1,25 @@
+This is not needed and causes problems with more strict
+implementations of libtool.
+
+With slibtool it fails.
+
+--- a/backend/Makefile
++++ b/backend/Makefile
+@@ -118,7 +118,7 @@ install-exec: $(INSTALLXPC)
+ echo Installing backends in $(SERVERBIN)/backend
+ $(INSTALL_DIR) -m 755 $(SERVERBIN)/backend
+ for file in $(RBACKENDS); do \
+- $(LIBTOOL) $(INSTALL_BIN) -m 700 $$file $(SERVERBIN)/backend; \
++ $(INSTALL_BIN) -m 700 $$file $(SERVERBIN)/backend; \
+ done
+ for file in $(UBACKENDS); do \
+ $(INSTALL_BIN) $$file $(SERVERBIN)/backend; \
+@@ -142,7 +142,7 @@ install-exec: $(INSTALLXPC)
+ install-xpc: ipp
+ echo Installing XPC backends in $(SERVERBIN)/apple
+ $(INSTALL_DIR) -m 755 $(SERVERBIN)/apple
+- $(LIBTOOL) $(INSTALL_BIN) ipp $(SERVERBIN)/apple
++ $(INSTALL_BIN) ipp $(SERVERBIN)/apple
+ for file in $(IPPALIASES); do \
+ $(RM) $(SERVERBIN)/apple/$$file; \
+ $(LN) ipp $(SERVERBIN)/apple/$$file; \