summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Manifest.gzbin7936 -> 7933 bytes
-rw-r--r--net-p2p/retroshare/Manifest3
-rw-r--r--net-p2p/retroshare/files/retroshare-0.6.5-qt-5.15.patch99
-rw-r--r--net-p2p/retroshare/retroshare-0.6.5.ebuild13
-rw-r--r--net-p2p/tremc/Manifest5
-rw-r--r--net-p2p/tremc/files/0.9.1-fix-startup-crash.patch62
-rw-r--r--net-p2p/tremc/tremc-0.9.2.ebuild (renamed from net-p2p/tremc/tremc-0.9.1.ebuild)20
7 files changed, 120 insertions, 82 deletions
diff --git a/net-p2p/Manifest.gz b/net-p2p/Manifest.gz
index db121fad0c98..0650f15eac19 100644
--- a/net-p2p/Manifest.gz
+++ b/net-p2p/Manifest.gz
Binary files differ
diff --git a/net-p2p/retroshare/Manifest b/net-p2p/retroshare/Manifest
index 3eb8187db26e..aee0a969f7dd 100644
--- a/net-p2p/retroshare/Manifest
+++ b/net-p2p/retroshare/Manifest
@@ -1,3 +1,4 @@
+AUX retroshare-0.6.5-qt-5.15.patch 2927 BLAKE2B a6e24b46af2df2592b482492b3c53049c4d089f8e4c4f6dd1d3a262945284353b1fde488c141bbae335851108887d2bda6c2e37aa91410885b1448dcfb300e4b SHA512 1b5c2debf192b9801a95d6640c079c7c3d2535cd59ca10f712e8123b1b35781cb7c0ef3fc2ff876c5582bbdb1b1c8efe7ffc666f4cfa365c1c429dd67a83ea37
DIST retroshare-0.6.5.tar.gz 29377995 BLAKE2B 3a8909227080702e42e59b42301e873d4ece806e014a959080a3ae9df7d11564a6e6d915087a9ddd6d5c66d1e5c43895fa24dea8c0042fdce391c384a54182ee SHA512 a65fefb6baff42a81880a401c9005f73ac8180a247dd992a350f9bf5bac366ee6e809bf93cbbc31e80646156147a1d434306dadfbed1f69879ab61cfae3fddeb
-EBUILD retroshare-0.6.5.ebuild 3979 BLAKE2B 35db0f242692977c06de9243a4ee76862a74f38560989cca51d40fbbe1c9ba551559604d9c2bd3a1e88a111c50aceea58ee6dd3c5afb51633d625c9fa1802d34 SHA512 19edf671bd9b754d031848b8f20c068e0b41e51b95c2a6ea3f2ba85b55ccb77fd98e9c634fb4592b44cf5ae62d5be27b0115d76cbaef542aa30eb4814c0ae26a
+EBUILD retroshare-0.6.5.ebuild 4113 BLAKE2B 8b7711204faba503a21083b93575069de216bd9035e344c9314387600e076d996dc3a26bcff78675a4ecaa282b0c8812ba4407010083e4083aac5cfd1e086f1d SHA512 3194e2f6b63233c981dac0451f47ee6a33a7e407063b25f08686d9e01b6f56f9eca2afde3ddcfaae46780f9f9d46f686ebc846fc235763b108d58e437514bcda
MISC metadata.xml 1584 BLAKE2B 35f66764610422f5ae44273f336d84668035cea9458da32e4af81edf162ce1c83b4e6d4d4d7d17a27a2b9ed4bcef7caff9efbd05b8bcee2bb00d33860fa4b63e SHA512 353333842e9c3335e57795447850dfe56ac29865c27232080b97f293d2c1fda89c9d1a47942861428f3b2a69f8fca5b7389f9a15b3fcfa8bd89b7ea8314f3114
diff --git a/net-p2p/retroshare/files/retroshare-0.6.5-qt-5.15.patch b/net-p2p/retroshare/files/retroshare-0.6.5-qt-5.15.patch
new file mode 100644
index 000000000000..21147a6391b0
--- /dev/null
+++ b/net-p2p/retroshare/files/retroshare-0.6.5-qt-5.15.patch
@@ -0,0 +1,99 @@
+From bbaad838572b5fba6109bc7d3b5c55c2c68e6cdc Mon Sep 17 00:00:00 2001
+From: Phenom <retrosharephenom@gmail.com>
+Date: Mon, 1 Jun 2020 13:44:43 +0200
+Subject: [PATCH] Fix build with Qt 5.15+
+
+---
+ retroshare-gui/src/gui/elastic/elnode.h | 8 +++++---
+ .../src/gui/gxs/GxsCommentTreeWidget.cpp | 16 +++++++++-------
+ retroshare-gui/src/gui/gxs/GxsIdDetails.cpp | 18 ++++++++++--------
+ 3 files changed, 24 insertions(+), 18 deletions(-)
+
+diff --git a/retroshare-gui/src/gui/elastic/elnode.h b/retroshare-gui/src/gui/elastic/elnode.h
+index 1e0edd1a87..33043ddab3 100644
+--- a/retroshare-gui/src/gui/elastic/elnode.h
++++ b/retroshare-gui/src/gui/elastic/elnode.h
+@@ -26,6 +26,10 @@
+ #ifndef ELNODE_H
+ #define ELNODE_H
+
++#include "graphwidget.h"
++
++#include <retroshare/rstypes.h>
++
+ #include <QApplication>
+ #if QT_VERSION >= 0x040600
+ #include <QGraphicsObject>
+@@ -36,9 +40,7 @@
+ #include <QGraphicsItem>
+ #endif
+ #include <QList>
+-
+-#include <retroshare/rstypes.h>
+-#include "graphwidget.h"
++#include <QPainterPath>
+
+ class Edge;
+ QT_BEGIN_NAMESPACE
+--- a/retroshare-gui/src/gui/gxs/GxsCommentTreeWidget.cpp
++++ b/retroshare-gui/src/gui/gxs/GxsCommentTreeWidget.cpp
+@@ -18,6 +18,12 @@
+ * *
+ *******************************************************************************/
+
++#include "GxsCommentTreeWidget.h"
++
++#include "gui/common/RSElidedItemDelegate.h"
++#include "gui/gxs/GxsCreateCommentDialog.h"
++#include "gui/gxs/GxsIdTreeWidgetItem.h"
++
+ #include <QAbstractTextDocumentLayout>
+ #include <QApplication>
+ #include <QClipboard>
+@@ -25,13 +31,9 @@
+ #include <QMenu>
+ #include <QMimeData>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QTextDocument>
+
+-#include "gui/common/RSElidedItemDelegate.h"
+-#include "gui/gxs/GxsCommentTreeWidget.h"
+-#include "gui/gxs/GxsCreateCommentDialog.h"
+-#include "gui/gxs/GxsIdTreeWidgetItem.h"
+-
+ #include <iostream>
+
+ #define PCITEM_COLUMN_COMMENT 0
+diff --git a/retroshare-gui/src/gui/gxs/GxsIdDetails.cpp b/retroshare-gui/src/gui/gxs/GxsIdDetails.cpp
+--- a/retroshare-gui/src/gui/gxs/GxsIdDetails.cpp
++++ b/retroshare-gui/src/gui/gxs/GxsIdDetails.cpp
+@@ -18,19 +18,21 @@
+ * *
+ *******************************************************************************/
+
+-#include <QApplication>
+-#include <QThread>
+-#include <QTimerEvent>
+-#include <QMutexLocker>
++#include "GxsIdDetails.h"
+
+-#include <math.h>
+-#include "GxsIdDetails.h"
+ #include "retroshare-gui/RsAutoUpdatePage.h"
+
+ #include <retroshare/rspeers.h>
+
+-#include <iostream>
++#include <QApplication>
++#include <QMutexLocker>
+ #include <QPainter>
++#include <QPainterPath>
++#include <QThread>
++#include <QTimerEvent>
++
++#include <iostream>
++#include <cmath>
+
+ /* Images for tag icons */
+ #define IMAGE_LOADING ":/images/folder-draft.png"
diff --git a/net-p2p/retroshare/retroshare-0.6.5.ebuild b/net-p2p/retroshare/retroshare-0.6.5.ebuild
index ab3d11026c9f..b2c53a2a2839 100644
--- a/net-p2p/retroshare/retroshare-0.6.5.ebuild
+++ b/net-p2p/retroshare/retroshare-0.6.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop qmake-utils xdg-utils
+inherit desktop eutils qmake-utils xdg-utils
DESCRIPTION="P2P private sharing application"
HOMEPAGE="https://retroshare.cc"
@@ -13,7 +13,6 @@ SRC_URI="https://github.com/RetroShare/RetroShare/releases/download/v${PV}/Retro
LICENSE="AGPL-3 GPL-2 GPL-3 Apache-2.0 LGPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-
IUSE="cli control-socket gnome-keyring +gui +jsonapi service +sqlcipher webui +xapian"
REQUIRED_USE="
@@ -60,10 +59,14 @@ BDEPEND="dev-util/cmake
)
)"
-src_unpack() {
- default
+PATCHES=( "${FILESDIR}/${P}-qt-5.15.patch" )
- mv RetroShare ${P} || die
+S="${WORKDIR}"/RetroShare
+
+src_prepare() {
+ # CRLF endings break patch...
+ edos2unix retroshare-gui/src/gui/elastic/elnode.h
+ default
}
src_configure() {
diff --git a/net-p2p/tremc/Manifest b/net-p2p/tremc/Manifest
index 9deb92103253..1cc014021fd4 100644
--- a/net-p2p/tremc/Manifest
+++ b/net-p2p/tremc/Manifest
@@ -1,4 +1,3 @@
-AUX 0.9.1-fix-startup-crash.patch 2298 BLAKE2B 0cc6ecfb473d93a6bda34a3d8ebcc9a66d176280bad2d6f356077a2f026540fdcaf5d130475fb687c8292d0402ea6f264a7b67d6a9abd8f9f4356802c0c746b6 SHA512 90d4eebf3913a58bbf8c4e8175c486d1819d6804598320df9cd58a04b6c6c88e06640ca8affc495e6f9c6ceed30b2290982ba774013fbc7f07011f2948936fee
-DIST tremc-0.9.1.tar.gz 315482 BLAKE2B c4e94ef13cc9d716cdbcbff061b1956d17c6babe765e192d675d08ad5d76a22cf171a4fb3f5f2952b971f59a16a2768ccd360d10df5b0f3325fd63ff9716f209 SHA512 ed16080c6544ce9019e6a0c4d660310992cae0f139a2a78e9eaa51841e293cefb22160a105794b5f03a4bfd47a2c50402879f2a17302a96265a9c9acb3174c39
-EBUILD tremc-0.9.1.ebuild 1031 BLAKE2B ec315485a068309eddaa5854bbf83ce5c781d11a30712345be4a1a895ff956ec74b2814c57493f968f30a289388784cb1e7244d232366bd2b0c0432ac213ba46 SHA512 e508957f347a3b59244d7228e6b794bdc79c54b76d3b1ac2966e04a469161dd93d54d83c3e2a861a5fb6019fda1a5bffcb896bc44bf7d23fc1d2c35927f996a0
+DIST tremc-0.9.2.tar.gz 315631 BLAKE2B f5ed154fbfcbdb3e77b678a5827d3f68a6be4033530d6d4e451d57808d43cd5737fff32cf62445d246bfce4d8f02e4cac0c1156603e220e228e61b725d6deaf8 SHA512 d6d6d155ddac918d329226d5c3b53c63fd4fa0b98e30f1eb2cd2226ea598bd7dd81d72f747dc11f4a508bcc0453d90d774c1d8db6dac05ae1ecbc217290b7db3
+EBUILD tremc-0.9.2.ebuild 1002 BLAKE2B 1dcb7a16fb9b0882a464c49ada7b4ca28b5d10f27528202b276f3d9f90a925a4e326b478d18faad5cd8d72814ba2f6f732c3a82c3513a624ef907e54d6037190 SHA512 022c67f441c1b949c9d9a899b9a5338cc1e877796a81afe6795a2f2a38d428e6a4acd9299d49ffa86ee5965dd58ed4d422e9fdffd6a86a96418024224d45228e
MISC metadata.xml 446 BLAKE2B 3736ac4b139f7c444823e0cf0b5adc3ffcde92bc00543fcc2bd9e23139a3ccb2c192dbbbc6b5e96586ceb61b31b7ac2d3298ee30e0b651880074788c25c2822f SHA512 75208e11a6c89db930bba12b4f120538757ccac5a45fa54b3c6c7e717131d93845453233585f68f8e77fb5abed72a7e91e94a4c1e04f8e3f8986b4de5a7d3e54
diff --git a/net-p2p/tremc/files/0.9.1-fix-startup-crash.patch b/net-p2p/tremc/files/0.9.1-fix-startup-crash.patch
deleted file mode 100644
index 5e67e5d31555..000000000000
--- a/net-p2p/tremc/files/0.9.1-fix-startup-crash.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 0cb919b446eeda41aea8578ae26796ae92a973e5 Mon Sep 17 00:00:00 2001
-From: George Angelopoulos <george@usermod.net>
-Date: Mon, 2 Jul 2018 17:55:38 +0200
-Subject: [PATCH] fix addch ERR crash when starting with no torrents
-
-There was a bug introduced by commit e06d08d:
- scale_bytes: Simplify this function
-
-tremc would crash when started against a transmission-daemon with no
-torrents.
-
-This was because scale_bytes(0) used to return 0K but now it returns
-0.0K. The expected width of 2 was hardcoded. The new width of 4 causes
-addch() to return ERR because it tries to draw outside the window.
-
-Hardcoding the new width to 4 would resolve this issue. Instead,
-this patch dynamically sets the width returned by scale_bytes().
-This should make the code a tiny bit more readable and maybe avoid this
-issue in the future.
-
-There is one more magic number involved here which I don't see a good
-way of getting rid of. So I made an illustrative comment.
-
-Resolves #15
----
- tremc | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/tremc b/tremc
-index 36ae67b..ed898fb 100755
---- a/tremc
-+++ b/tremc
-@@ -883,7 +883,7 @@ class Interface(object):
- self.focus = -1 # -1: nothing focused; 0: top of list; <# of torrents>-1: bottom of list
- self.scrollpos = 0 # start of torrentlist
- self.torrents_per_page = 0 # will be set by manage_layout()
-- self.rateDownload_width = self.rateUpload_width = 2
-+ self.rateDownload_width = self.rateUpload_width = len(scale_bytes())
-
- self.details_category_focus = 0 # overview/files/peers/tracker in details
- self.focus_detaillist = -1 # same as focus but for details
-@@ -2667,6 +2667,8 @@ class Interface(object):
- pass
-
- def draw_global_rates(self):
-+ # ↑1.2K ↓3.4M
-+ # ^ ^^ => +3
- rates_width = self.rateDownload_width + self.rateUpload_width + 3
-
- if self.stats['alt-speed-enabled']:
-@@ -3373,7 +3375,7 @@ def timestamp(timestamp, format="%x %X"):
- return "%s (%s)" % (absolute, relative)
-
-
--def scale_bytes(bytes, type='short'):
-+def scale_bytes(bytes=0, type='short'):
- if bytes >= 1099511627776:
- scaled_bytes = round((bytes / 1099511627776.0), 1)
- unit = 'T'
---
-2.26.0
-
diff --git a/net-p2p/tremc/tremc-0.9.1.ebuild b/net-p2p/tremc/tremc-0.9.2.ebuild
index 8306b1e2dfac..2c02ce97e8da 100644
--- a/net-p2p/tremc/tremc-0.9.1.ebuild
+++ b/net-p2p/tremc/tremc-0.9.2.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7,8} )
PYTHON_REQ_USE="ncurses"
-inherit bash-completion-r1 python-single-r1
+inherit bash-completion-r1 eutils python-single-r1
DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
HOMEPAGE="https://github.com/tremc/tremc"
@@ -14,17 +14,9 @@ SRC_URI="https://github.com/tremc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="geoip"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
- ')
-"
-
-# This fixes a crash when starting that was committed after 0.9.1
-PATCHES=( "${FILESDIR}/${PV}-fix-startup-crash.patch" )
+RDEPEND="${PYTHON_DEPS}"
# Specify a no-op src_compile so upstream's broken Makefile doesn't get used
src_compile() {
@@ -39,3 +31,9 @@ src_install() {
doman tremc.1
dodoc NEWS README.md
}
+
+pkg_postinst() {
+ optfeature "GeoIP support" dev-python/geoip-python
+ optfeature "Extract ipv4 from ipv6 addresses" dev-python/ipy
+ optfeature "Clipboard support" dev-python/pyperclip
+}