summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Manifest.gzbin6761 -> 6762 bytes
-rw-r--r--net-p2p/kubo/Manifest2
-rw-r--r--net-p2p/kubo/kubo-0.20.0.ebuild69
-rw-r--r--net-p2p/qbittorrent/Manifest4
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild5
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild5
6 files changed, 79 insertions, 6 deletions
diff --git a/net-p2p/Manifest.gz b/net-p2p/Manifest.gz
index 4f24e583cdac..f8acd946a0bf 100644
--- a/net-p2p/Manifest.gz
+++ b/net-p2p/Manifest.gz
Binary files differ
diff --git a/net-p2p/kubo/Manifest b/net-p2p/kubo/Manifest
index af808da8b0ea..2b3c72793028 100644
--- a/net-p2p/kubo/Manifest
+++ b/net-p2p/kubo/Manifest
@@ -4,6 +4,8 @@ AUX ipfs.init 464 BLAKE2B 553288784ba3df93037f640663d7ed3539f9a55e72ee9a36a9708e
AUX ipfs.service 372 BLAKE2B 8989cc474ab46309dda6d167fb89476b01d10e07374d53c480a7ee345f13827e25ca19d84b0a3974e45c5d9a0c78abdfd7be262bff48f427aedaac2a9c4094a8 SHA512 35d5edda83bd296f92ffe3ee61f2608eb9ec464225e32ca52582d8e8fe699466c9b412ed224ff44e36e34d3d41a618d50082dd677feeaba53429d3a6913a869a
DIST kubo-0.15.0.tar.gz 13318096 BLAKE2B 92a97eea130d24065c5d8a60ee7eb9b2bd3afba94596c0b538b04970277df11bf11f1cfc8399b303cea58cd249a86f956174d6544e6b6a94b34722ecdd20671a SHA512 26c1945c4ce641953e72a8f08802aa5acdd6c39fee3c1306bec0613a36b3d1ad79e23f7531427631848a6952ed950d27cd6a09f18352043bc145669b491843e6
DIST kubo-0.18.1.tar.gz 13582874 BLAKE2B bc5ae67a476e796d774b47d29a5338cf2d1f1029197177bc69a36be255502bf12b45a8c6f5c4009ea100c749d73addc2195ce308e52883c8a36fecd08df26850 SHA512 eb6245abfef2079980f67f6a2dffad36346d06587df754d8477eeeda96464d9fa1428bb5d9ae628cca3ffa6a52c66c20e980c5a20ade389c1089aba947df6365
+DIST kubo-0.20.0.tar.gz 15476743 BLAKE2B 8b7e58f18c1342981f575545c6e11a167df240bb0d6d0712bcb3fd6a0aa7f84a6737af06d2ae89fe998ee715be5c0e0c39f4ce83685ae238008c46f48c6cf7a1 SHA512 5231efce18dbb6491fa6665db8d1522efcb2d7278203259714b77d655060765922e9076addb1de3e10950c2c7aa3c9e24e2114879c3e4ce1fceef69755b12eaf
EBUILD kubo-0.15.0.ebuild 1771 BLAKE2B 9e73805889ff6404d82e59491c70b6f8cc04b3398d25de6b5e03780cb07125c097d8ce701e463a56bd8139bd219d9b315bc4f181c2a4586dc133b2ecc6c3d483 SHA512 97f722facbf10e1a7928f55714439af111a2f3e9d70b4f19fc916689cc1e1c515a5fe4c075aa54888e53e68fbacfe0f5a7878d859e3594d38766f254f4b14aac
EBUILD kubo-0.18.1.ebuild 1771 BLAKE2B bce5adfd7fc1435347c357d8469846bd49d203ab102c967e958736254dbef46596f9b51d937c74e5616cd8b097bd4acd229ddebaf74b87d822e984af804e80c3 SHA512 c481f6758f069ca71346bfdbf0f66eac25a02acbeaf5597d31abbedf0c4288d56ae2639a70e1b202a501d14be40548827a1df94d7305caeea6d90551917c757a
+EBUILD kubo-0.20.0.ebuild 1771 BLAKE2B bce5adfd7fc1435347c357d8469846bd49d203ab102c967e958736254dbef46596f9b51d937c74e5616cd8b097bd4acd229ddebaf74b87d822e984af804e80c3 SHA512 c481f6758f069ca71346bfdbf0f66eac25a02acbeaf5597d31abbedf0c4288d56ae2639a70e1b202a501d14be40548827a1df94d7305caeea6d90551917c757a
MISC metadata.xml 596 BLAKE2B 68c5576e325ef2e0a6954047b8784427ca8b1d038c4b7fc7a7f2082e2682dbb8b807083251c9e5eca927d070d21b1f5ee9f96e2cb2437a9f5934bdc46f139fb6 SHA512 2d41af83abc0527e9031f8bec8d471dc7d163714bb42b9d7f65c943993e7d554207a5fb85ad96ae94c7876a74e2b3c8dba6a8f70e4f1bbb5a785bb98624233a9
diff --git a/net-p2p/kubo/kubo-0.20.0.ebuild b/net-p2p/kubo/kubo-0.20.0.ebuild
new file mode 100644
index 000000000000..6cd5d94e6814
--- /dev/null
+++ b/net-p2p/kubo/kubo-0.20.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.io/ https://github.com/ipfs/kubo/"
+SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/kubo-source.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/ipfs
+ acct-user/ipfs
+ sys-fs/fuse:0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-lang/go"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
+
+S="${WORKDIR}"
+
+src_compile() {
+ local mygoargs
+ mygoargs=(
+ -tags release
+ )
+
+ ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
+ ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
+
+ IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
+}
+
+src_test() {
+ ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
+}
+
+src_install() {
+ dobin ipfs
+ dobin ipfswatch
+ newbashcomp ipfs-completion.bash ipfs
+ einstalldocs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
+
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ keepdir /var/log/ipfs
+ fowners -R ipfs:ipfs /var/log/ipfs
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+
+ # See https://bugs.gentoo.org/838238
+ ewarn 'In case kubo CPU usage is too high run the next workaround'
+ ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
+ ewarn 'Be aware that this will make your node less visible to other peers'
+}
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 7b3518e1e9a2..54d942a46e7b 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,4 +1,4 @@
DIST qbittorrent-4.5.2.tar.gz 8890525 BLAKE2B 48585b703ce6edf862ea3c8cfad6cab2edcb65a138c6e8d232322b4f4fd682c87447ff11d29c04c26b5623e730ab9a1ce0496456b3ba6122f97913bd92b86790 SHA512 e900a1c5f0f70163463557aec3de0d31394fac56cfed91ea53ee5cf852cce4b2998bf79be60fc547c1c34a1658378f3ed9dbfb30aae5a772b85d819c7e7ce458
-EBUILD qbittorrent-4.5.2.ebuild 2193 BLAKE2B e7593b249cca812a034a35cb9ba1538ef00fcac86817268e0554caaa2e87a6cb6c3a6c571fe713e43a7f7c080212931ed69fc90571616428966c73802839caf7 SHA512 6a3098cda4e7ffe9bca9bc310c942482d69ba3f009ad9276c88ed4e98166dc550b1ee35d923f98a2a64a6c1e572018764aae25bb251937956b5e0e17f7992a3f
-EBUILD qbittorrent-9999.ebuild 2654 BLAKE2B 829ac53a41b19cff2d3e5ef336a318a7c7cdd549170309efe097a8a0269d121c26aaf165f5e23aeadb4420069af7ca6f8ce8ac3921442d88fe7ff71e4b052f1a SHA512 3b31f1b971842302b126da635e0b7982f148cb0dd71f57ff0a95a0707140cfb0f61237709fa70d94a6b1945b0667d42af99893dc1bc724afde2cfe142046d954
+EBUILD qbittorrent-4.5.2.ebuild 2193 BLAKE2B a1cca9de23750e3a0b3a724f7ba21b0b398a97202fc0a41fd8efb10039e5e4a67bf97c97d4662855672c85ec398718699c2befd953339dac42259a49142ba2a8 SHA512 2c06ef6f6c768ed51f769a367fee57c82948f7d09d578c0bd1408e4ac7a525b4ca003b0124d77b666014b483792084262bb7be5be905a4ef09285b3d59bdebae
+EBUILD qbittorrent-9999.ebuild 2654 BLAKE2B 51a384295b444603120b7e5e18b9b37f0faad05483be7bf43614ac984cd21b6cc5a965abde0cf379dd8211e0fede18bb1daf6542dd9341185afa3e961d417fdd SHA512 b102f0563325040fcab1ef32d9090605c5a30f27833458164fc5afb4d9dc8ef1ea2f94fb49c3e7ea640085bf289b79ae6ac34e238038f8d86646b80790165725
MISC metadata.xml 458 BLAKE2B 8c13d95038dafa12073f44243d8881ec80deaf0f4802da0590b944a4eb99731e6ac8064b0c24a1ef5e7228409ecb5c37031efe6f14bd949170cbc25efd06fb5b SHA512 550b920dfb04cc2b18d1c993af8fe989fd4b7e58a97dd619f45b08eb051b9ceb7f22f0defe9c2bda40bea3e626c9f32b47903474f6216f8ebdcdf40f44b9fe3d
diff --git a/net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild b/net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild
index 8de609b04140..dde05ed0e8f3 100644
--- a/net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-4.5.2.ebuild
@@ -24,7 +24,6 @@ REQUIRED_USE="dbus? ( gui )
|| ( gui webui )"
RDEPEND="
- dev-libs/boost:=
>=dev-libs/openssl-1.1.1:=
dev-qt/qtcore:5
dev-qt/qtnetwork:5[ssl]
@@ -39,7 +38,9 @@ RDEPEND="
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
)"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost"
BDEPEND="dev-qt/linguist-tools:5
virtual/pkgconfig"
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 42048dfcddbe..eeba63e2c817 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -24,7 +24,6 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( gui webui )"
RDEPEND="
- dev-libs/boost:=
>=dev-libs/openssl-1.1.1:=
>=net-libs/libtorrent-rasterbar-1.2.18:=
>=sys-libs/zlib-1.2.11
@@ -49,7 +48,9 @@ RDEPEND="
dev-qt/qtsql:5[sqlite]
dev-qt/qtxml:5
)"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
test? (
!qt6? ( dev-qt/qttest:5 )
qt6? ( dev-qt/qtbase:6[test] )