summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Manifest.gzbin6903 -> 6904 bytes
-rw-r--r--net-p2p/retroshare/Manifest4
-rw-r--r--net-p2p/retroshare/metadata.xml1
-rw-r--r--net-p2p/retroshare/retroshare-0.6.7.ebuild138
4 files changed, 142 insertions, 1 deletions
diff --git a/net-p2p/Manifest.gz b/net-p2p/Manifest.gz
index a45fb3fab52e..957308d2be60 100644
--- a/net-p2p/Manifest.gz
+++ b/net-p2p/Manifest.gz
Binary files differ
diff --git a/net-p2p/retroshare/Manifest b/net-p2p/retroshare/Manifest
index 3d9103bb8139..1dde5b5ef704 100644
--- a/net-p2p/retroshare/Manifest
+++ b/net-p2p/retroshare/Manifest
@@ -1,4 +1,6 @@
AUX retroshare-0.6.6-fix-cxx17-compilation.patch 1753 BLAKE2B aeba3e200eaf78867220227b766d2e396322d93e14afa885ba8ac5d8d5c88b9806a1fc90a00b2e7a364cdfcfa04776da9974293a394fc4d946ca30716daf931c SHA512 09f146aaaa9570eb4b01a9b325acbf6648d88ddde222128f709ecc89038ce5d8c9fba046abdf36547b4ee7e653bf058a3a51f775a78e71b760e0e513d43005e6
DIST retroshare-0.6.6.tar.gz 24140207 BLAKE2B 1328f2d36f6bc2d1123dd915698f2778e771e36089d8fd8d9ec44d1a8bfa0f56c625b73f62811936e4cee5dd1eca797f9fdf16fdb8defd66706294abc4dde419 SHA512 23ed7c633426caa910a5ae6f04cfd33c523ecaedae1e4044981706420622aadd67ba2772ffd17c9cc1c6193fad508837a31fdcfabe2aab309b8b4302335ede4d
+DIST retroshare-0.6.7.tar.gz 26506259 BLAKE2B 3c0963c8afbbf741c8c5d22dc9c9f86f82d1a338a9f0dd02065617d16e96738a4d22c2bc30c1ba32c61fcc7beedaa15ac3c185aab429882b0947aa28b8c037b1 SHA512 ff5455b97519878d83c6872dfce457804430938864259f7d0fa5b06ebae161e62ea8300e809a03a821b2ecdf755a3de7465a580882709ae79bfb9c1de855e347
EBUILD retroshare-0.6.6-r1.ebuild 3601 BLAKE2B d3d4c76e78f502becceb26f967f6787f71476e7bee761558144ee6bed00c62659dd6cba963ad780e94ba69105a254e72df0a76adc7981e8d540f98ea15a976fe SHA512 2eff59bc8aef1650b2cd33b68037736dba6353f383b9bcb99253be84877ffff9482ca6eca5b2a810b470b00dc2d55c24662abe341d836d2c5e9518337f37f0dc
-MISC metadata.xml 1454 BLAKE2B 1876c70398f3e387adc282a8ff0d1fc175605cd1e6912e9f52a446419e37b208ea0dcc6b042c13e3feeae2f70369abb9ceece68c9132365bd053d675ce681198 SHA512 03c75535fb7d4fa9ac13f691f47b4dc2e607cb7fe1aaed5286882ec5ff3bec9bf1ccfabfb24503b266eed3d8013eafe21e9bcd2d8efa7cac7e88cc5898ac70d2
+EBUILD retroshare-0.6.7.ebuild 4072 BLAKE2B 26d172588c60710b4dddf6aac0f1d774e5d056aaabd96bd2e08593e1911278d8964e8b046f51cbf58eee9dbe82fafb4a0cb87110ee591e03e46702549f7bffd8 SHA512 430b8737aac31a970171b1dc0b5aead3ff227b845588d4a3297bd3f477ab2499803f58d2347530a2658b915d891b6d05ecec90d001b43fc68a40053cacd9c6db
+MISC metadata.xml 1507 BLAKE2B 3850886e6d5e70ad585ec4083d5fb86a01b962a421cfbeac26862e47dada0adf0cbfa53e31bbbd34b968da72e6395560a6c48b6125e9996f82df2089e383f9a7 SHA512 26cd8010b552892041a688525345922a3412f50d060c319b3c5bf9f135e21d5b1e7bd61b09b91431f716d695471e70b1c9a2c62772b0d3847806e4a923c48382
diff --git a/net-p2p/retroshare/metadata.xml b/net-p2p/retroshare/metadata.xml
index a784b5ae777f..4388bd9dcb1d 100644
--- a/net-p2p/retroshare/metadata.xml
+++ b/net-p2p/retroshare/metadata.xml
@@ -22,6 +22,7 @@
<flag name="jsonapi">Enables the new RetroShare JSON API</flag>
<flag name="libupnp">Enables UPnP port forwarding via <pkg>net-libs/libupnp</pkg></flag>
<flag name="miniupnp">Enables UPnP port forwarding via <pkg>net-libs/miniupnpc</pkg></flag>
+ <flag name="plugins">Enables plugin support</flag>
<flag name="service">Enables the new RetroShare service</flag>
<flag name="sqlcipher">Enables GXS database encryption via SQLCipher</flag>
</use>
diff --git a/net-p2p/retroshare/retroshare-0.6.7.ebuild b/net-p2p/retroshare/retroshare-0.6.7.ebuild
new file mode 100644
index 000000000000..d33aa29b2933
--- /dev/null
+++ b/net-p2p/retroshare/retroshare-0.6.7.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic desktop qmake-utils xdg
+
+DESCRIPTION="Friend to Friend secure communication and sharing application"
+HOMEPAGE="https://retroshare.cc"
+SRC_URI="https://download.opensuse.org/repositories/network:/retroshare/Debian_Testing/retroshare-common_${PV}.orig.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/RetroShare"
+# NOTE: GitHub releases/archive is impractical to build so we use the OBS repo
+
+LICENSE="AGPL-3 Apache-2.0 CC-BY-SA-4.0 GPL-2 GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="keyring cli +gui +jsonapi libupnp +miniupnp +service +sqlcipher plugins"
+
+REQUIRED_USE="
+ || ( gui service )
+ ?? ( libupnp miniupnp )
+ plugins? ( gui )
+ service? ( || ( cli jsonapi ) )"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ keyring? ( app-crypt/libsecret )
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtxml:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ libupnp? ( net-libs/libupnp:= )
+ miniupnp? ( net-libs/miniupnpc:= )
+ sqlcipher? ( dev-db/sqlcipher )
+ !sqlcipher? ( dev-db/sqlite:3 )
+ plugins? (
+ media-libs/speex
+ media-libs/speexdsp
+ <media-video/ffmpeg-5
+ )"
+
+# NOTE(setan): rapidjson might not be needed if not using jsonapi. This is to be tested
+DEPEND="${RDEPEND}
+ >=dev-libs/rapidjson-1.1.0
+ gui? ( dev-qt/designer:5 )"
+
+BDEPEND="dev-build/cmake
+ dev-qt/qtcore:5
+ virtual/pkgconfig
+ gui? ( x11-base/xorg-proto )
+ jsonapi? ( app-text/doxygen )"
+
+src_configure() {
+ local qconfigs=(
+ $(usex cli '' 'no_')rs_service_terminal_login
+ $(usex keyring '' 'no_')rs_autologin
+ $(usex gui '' 'no_')retroshare_gui
+ $(usex jsonapi '' 'no_')rs_jsonapi
+ $(usex service '' 'no_')retroshare_service
+ $(usex sqlcipher '' 'no_')sqlcipher
+ $(usex plugins '' 'no_')retroshare_plugins
+ )
+
+ local qupnplibs="none"
+ use miniupnp && qupnplibs="miniupnpc"
+ use libupnp && qupnplibs="upnp ixml"
+
+ # bug 907898
+ use elibc_musl && append-flags -D_LARGEFILE64_SOURCE
+
+ # REVIEW: qmake is deprecated
+ # https://github.com/RetroShare/RetroShare/tree/master/jsonapi-generator
+ eqmake5 CONFIG+="${qconfigs[*]}" \
+ RS_MAJOR_VERSION=$(ver_cut 1) RS_MINOR_VERSION=$(ver_cut 2) \
+ RS_MINI_VERSION=$(ver_cut 3) RS_EXTRA_VERSION="-gentoo-${PR}" \
+ RS_UPNP_LIB="${qupnplibs}"
+}
+
+src_install() {
+ use gui && dobin retroshare-gui/src/retroshare
+ use service && dobin retroshare-service/src/retroshare-service
+
+ insinto /usr/share/retroshare
+ doins libbitdht/src/bitdht/bdboot.txt
+ use gui && doins -r retroshare-gui/src/qss
+
+ dodoc README.asciidoc
+
+ if use gui; then
+ make_desktop_entry retroshare
+
+ for i in 24 48 64 128 ; do
+ doicon -s ${i} "data/${i}x${i}/apps/retroshare.png"
+ done
+ fi
+ if use plugins; then
+ insinto /usr/lib/retroshare/extensions6
+ doins plugins/*/lib/*.so
+ fi
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+
+ if ! use sqlcipher && ! has_version "net-p2p/retroshare[-sqlcipher]"; then
+ ewarn "You have disabled GXS database encryption, ${PN} will use SQLite"
+ ewarn "instead of SQLCipher for GXS databases."
+ ewarn "Builds using SQLite and builds using SQLCipher have incompatible"
+ ewarn "database format, so you will need to manually delete GXS"
+ ewarn "database (loosing all your GXS data and identities) when you"
+ ewarn "toggle sqlcipher USE flag."
+ fi
+
+ if [[ ${REPLACING_VERSIONS} ]]; then
+ if ver_test ${REPLACING_VERSIONS} -lt 0.6; then
+ ewarn "You are upgrading from Retroshare 0.5.* to ${PV}"
+ ewarn "Version 0.6.* is backward-incompatible with 0.5 branch"
+ ewarn "and clients with 0.6.* can not connect to clients that have 0.5.*"
+ ewarn "It's recommended to drop all your configuration and either"
+ ewarn "generate a new certificate or import existing from a backup"
+ break
+ fi
+ if ver_test ${REPLACING_VERSIONS} -ge 0.6.0 && ver_test ${REPLACING_VERSIONS} -lt 0.6.4; then
+ elog "Main executable has been renamed upstream from RetroShare06 to retroshare"
+ break
+ fi
+ fi
+}