summaryrefslogtreecommitdiff
path: root/net-p2p/tremc/tremc-0.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/tremc/tremc-0.9.3.ebuild')
-rw-r--r--net-p2p/tremc/tremc-0.9.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-p2p/tremc/tremc-0.9.3.ebuild b/net-p2p/tremc/tremc-0.9.3.ebuild
new file mode 100644
index 000000000000..bd259f46580c
--- /dev/null
+++ b/net-p2p/tremc/tremc-0.9.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit bash-completion-r1 optfeature python-single-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/tremc/tremc"
+SRC_URI="https://github.com/tremc/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+# Github tag tarballs include the repo with commit in the dir's name
+# Specify a no-op src_compile so upstream's broken Makefile doesn't get used
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript tremc
+ newbashcomp completion/bash/tremc.sh tremc
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/_tremc
+ doman tremc.1
+ dodoc NEWS README.md
+}
+
+pkg_postinst() {
+ optfeature "GeoIP support" dev-python/geoip-python
+ optfeature "Extract ipv4 from ipv6 addresses" dev-python/ipy
+ optfeature "Clipboard support" dev-python/pyperclip
+}