summaryrefslogtreecommitdiff
path: root/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild')
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild b/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild
deleted file mode 100644
index b2501a16acab..000000000000
--- a/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools linux-info systemd
-
-DESCRIPTION="BitTorrent Client using libtorrent"
-HOMEPAGE="https://rakshasa.github.io/rtorrent/"
-SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris"
-IUSE="daemon debug selinux test xmlrpc"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
- >=dev-libs/libsigc++-2.2.2:2
- >=net-misc/curl-7.19.1
- sys-libs/ncurses:0=
- xmlrpc? ( dev-libs/xmlrpc-c )"
-RDEPEND="${COMMON_DEPEND}
- daemon? ( app-misc/screen )
- selinux? ( sec-policy/selinux-rtorrent )
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/cppunit
- virtual/pkgconfig"
-
-DOCS=( doc/rtorrent.rc )
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.9.7-tinfo.patch"
- "${FILESDIR}/${PN}-0.9.7-execinfo-configure.patch"
-)
-
-pkg_setup() {
- if ! linux_config_exists || ! linux_chkconfig_present IPV6; then
- ewarn "rtorrent will not start without IPv6 support in your kernel"
- ewarn "without further configuration. Please set bind=0.0.0.0 or"
- ewarn "similar in your rtorrent.rc"
- ewarn "Upstream bug: https://github.com/rakshasa/rtorrent/issues/732"
- fi
-}
-
-src_prepare() {
- default
-
- # https://github.com/rakshasa/rtorrent/issues/332
- cp "${FILESDIR}"/rtorrent.1 "${S}"/doc/ || die
-
- eautoreconf
-}
-
-src_configure() {
- default
-
- # configure needs bash or script bombs out on some null shift, bug #291229
- CONFIG_SHELL=${BASH} econf \
- $(use_enable debug) \
- $(use_with xmlrpc xmlrpc-c)
-}
-
-src_install() {
- default
- doman doc/rtorrent.1
-
- if use daemon; then
- newinitd "${FILESDIR}/rtorrentd.init" rtorrentd
- newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd
- systemd_newunit "${FILESDIR}/rtorrentd_at.service" "rtorrentd@.service"
- fi
-}