summaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent/qbittorrent-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild64
1 files changed, 35 insertions, 29 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index f66536f7dc86..85869e0799fd 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit xdg-utils
+inherit cmake systemd xdg
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="https://www.qbittorrent.org
@@ -14,55 +14,61 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
else
SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~ppc64 x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
S="${WORKDIR}/qBittorrent-release-${PV}"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+dbus debug webui +X"
-REQUIRED_USE="dbus? ( X )"
+IUSE="+dbus +gui webui"
+REQUIRED_USE="dbus? ( gui )"
RDEPEND="
- >=dev-libs/boost-1.62.0-r1:=
+ >=dev-libs/boost-1.65.0-r1:=
+ dev-libs/openssl:=
dev-qt/qtcore:5
dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
dev-qt/qtxml:5
- >=net-libs/libtorrent-rasterbar-1.2.11:0=
+ >=net-libs/libtorrent-rasterbar-1.2.14:=
sys-libs/zlib
dbus? ( dev-qt/qtdbus:5 )
- X? (
+ gui? (
dev-libs/geoip
dev-qt/qtgui:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
)"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5"
-
-BDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
src_configure() {
- econf \
- $(use_enable dbus qt-dbus) \
- $(use_enable debug) \
- $(use_enable webui) \
- $(use_enable X gui)
-}
+ local mycmakeargs=(
+ -DDBUS=$(usex dbus)
+ -DGUI=$(usex gui)
+ -DWEBUI=$(usex webui)
-src_install() {
- emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
- einstalldocs
-}
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
+ # We always want to install unit files
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
+
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+
+ # Not yet in ::gentoo
+ -DQT6=OFF
+ )
+
+ cmake_src_configure
}
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
+src_install() {
+ cmake_src_install
+ einstalldocs
}