summaryrefslogtreecommitdiff
path: root/net-p2p/nicotine+/nicotine+-3.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/nicotine+/nicotine+-3.2.2-r1.ebuild')
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.2-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/nicotine+-3.2.2-r1.ebuild b/net-p2p/nicotine+/nicotine+-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..cc9c130b97f3
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.2.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+EPYTEST_IGNORE=(
+ "test/integration/test_startup.py"
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/nicotine" "${ED}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}