summaryrefslogtreecommitdiff
path: root/net-p2p/litecoind/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/litecoind/files')
-rw-r--r--net-p2p/litecoind/files/0.9.0-sys_leveldb.patch34
-rw-r--r--net-p2p/litecoind/files/litecoind-0.10.2.2-fix-gnustack.patch17
-rw-r--r--net-p2p/litecoind/files/litecoind-0.10.2.2-memenv_h.patch12
-rw-r--r--net-p2p/litecoind/files/litecoind-0.10.4.0-gcc6.patch47
4 files changed, 0 insertions, 110 deletions
diff --git a/net-p2p/litecoind/files/0.9.0-sys_leveldb.patch b/net-p2p/litecoind/files/0.9.0-sys_leveldb.patch
deleted file mode 100644
index 60e9f2b20941..000000000000
--- a/net-p2p/litecoind/files/0.9.0-sys_leveldb.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-commit c38e0af3e021eb0b2aba846c77b06ca71de06b11 (personal-github/sys_leveldb, sys_leveldb)
-Author: Luke Dashjr <luke-jr+git@utopios.org>
-Date: Mon Sep 9 03:06:17 2013 +0000
-
- configure: Add unsupported --with-system-leveldb configure flag
-
-diff --git a/configure.ac b/configure.ac
-index 3ed4549..5a5852d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -332,10 +332,22 @@ AC_TRY_COMPILE([#include <sys/socket.h>],
- [ AC_MSG_RESULT(no)]
- )
-
-+dnl Check for leveldb, only if explicitly requested
- LEVELDB_CPPFLAGS=
- LIBLEVELDB=
- LIBMEMENV=
--AM_CONDITIONAL([EMBEDDED_LEVELDB],[true])
-+AC_ARG_WITH([system-leveldb],
-+ [AS_HELP_STRING([--with-system-leveldb],
-+ [Build with system LevelDB (default is no; DANGEROUS; NOT SUPPORTED)])],
-+ [system_leveldb=$withval],
-+ [system_leveldb=no]
-+)
-+if test x$system_leveldb != xno; then
-+ LEVELDB_CPPFLAGS=
-+ LIBLEVELDB=-lleveldb
-+ LIBMEMENV=-lmemenv
-+fi
-+AM_CONDITIONAL([EMBEDDED_LEVELDB],[test x$system_leveldb = xno])
- AC_SUBST(LEVELDB_CPPFLAGS)
- AC_SUBST(LIBLEVELDB)
- AC_SUBST(LIBMEMENV)
diff --git a/net-p2p/litecoind/files/litecoind-0.10.2.2-fix-gnustack.patch b/net-p2p/litecoind/files/litecoind-0.10.2.2-fix-gnustack.patch
deleted file mode 100644
index cbaf66ea93e1..000000000000
--- a/net-p2p/litecoind/files/litecoind-0.10.2.2-fix-gnustack.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -Naur litecoin-0.10.2.2.orig/src/secp256k1/src/field_5x52_asm.asm litecoin-0.10.2.2/src/secp256k1/src/field_5x52_asm.asm
---- litecoin-0.10.2.2.orig/src/secp256k1/src/field_5x52_asm.asm 2015-06-15 04:51:30.000000000 -0400
-+++ litecoin-0.10.2.2/src/secp256k1/src/field_5x52_asm.asm 2016-01-03 08:35:26.438350565 -0500
-@@ -466,4 +466,12 @@
- jmp common_exit_norm
- end
-
--
-+%ifidn __OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
-+%ifidn __OUTPUT_FORMAT__,elf32
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
-+%ifidn __OUTPUT_FORMAT__,elf64
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
diff --git a/net-p2p/litecoind/files/litecoind-0.10.2.2-memenv_h.patch b/net-p2p/litecoind/files/litecoind-0.10.2.2-memenv_h.patch
deleted file mode 100644
index e181e4db5a91..000000000000
--- a/net-p2p/litecoind/files/litecoind-0.10.2.2-memenv_h.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur litecoin-0.10.2.2.orig/src/leveldbwrapper.cpp litecoin-0.10.2.2/src/leveldbwrapper.cpp
---- litecoin-0.10.2.2.orig/src/leveldbwrapper.cpp 2015-06-15 04:51:30.000000000 -0400
-+++ litecoin-0.10.2.2/src/leveldbwrapper.cpp 2015-08-28 21:30:45.968538185 -0400
-@@ -11,7 +11,7 @@
- #include <leveldb/cache.h>
- #include <leveldb/env.h>
- #include <leveldb/filter_policy.h>
--#include <memenv.h>
-+#include <leveldb/helpers/memenv.h>
-
- void HandleError(const leveldb::Status& status) throw(leveldb_error)
- {
diff --git a/net-p2p/litecoind/files/litecoind-0.10.4.0-gcc6.patch b/net-p2p/litecoind/files/litecoind-0.10.4.0-gcc6.patch
deleted file mode 100644
index 5c7e44da3d39..000000000000
--- a/net-p2p/litecoind/files/litecoind-0.10.4.0-gcc6.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 40ce41c006787dc4a2e3b17f7abbaf8ff56c45e7 Mon Sep 17 00:00:00 2001
-From: Adrian Gallagher <thrasher@addictionsoftware.com>
-Date: Tue, 25 Oct 2016 17:48:19 -0700
-Subject: [PATCH] Litecoin: Fix build boost compilation error with C++11
-
----
- src/chainparams.cpp | 20 ++++++++++----------
- 1 file changed, 10 insertions(+), 10 deletions(-)
-
-diff --git a/src/chainparams.cpp b/src/chainparams.cpp
-index ba8e33d1c14..7f99e45b7ad 100644
---- a/src/chainparams.cpp
-+++ b/src/chainparams.cpp
-@@ -163,11 +163,11 @@ class CMainParams : public CChainParams {
- vSeeds.push_back(CDNSSeedData("weminemnc.com", "dnsseed.weminemnc.com"));
- vSeeds.push_back(CDNSSeedData("loshan.co.uk", "seed-a.litecoin.loshan.co.uk"));
-
-- base58Prefixes[PUBKEY_ADDRESS] = list_of(48);
-- base58Prefixes[SCRIPT_ADDRESS] = list_of(5);
-- base58Prefixes[SECRET_KEY] = list_of(176);
-- base58Prefixes[EXT_PUBLIC_KEY] = list_of(0x04)(0x88)(0xB2)(0x1E);
-- base58Prefixes[EXT_SECRET_KEY] = list_of(0x04)(0x88)(0xAD)(0xE4);
-+ base58Prefixes[PUBKEY_ADDRESS] = std::vector<unsigned char>(1,48);
-+ base58Prefixes[SCRIPT_ADDRESS] = std::vector<unsigned char>(1,5);
-+ base58Prefixes[SECRET_KEY] = std::vector<unsigned char>(1,176);
-+ base58Prefixes[EXT_PUBLIC_KEY] = boost::assign::list_of(0x04)(0x88)(0xB2)(0x1E).convert_to_container<std::vector<unsigned char> >();
-+ base58Prefixes[EXT_SECRET_KEY] = boost::assign::list_of(0x04)(0x88)(0xAD)(0xE4).convert_to_container<std::vector<unsigned char> >();
-
- convertSeed6(vFixedSeeds, pnSeed6_main, ARRAYLEN(pnSeed6_main));
-
-@@ -225,11 +225,11 @@ class CTestNetParams : public CMainParams {
- vSeeds.push_back(CDNSSeedData("xurious.com", "testnet-seed.ltc.xurious.com"));
- vSeeds.push_back(CDNSSeedData("wemine-testnet.com", "dnsseed.wemine-testnet.com"));
-
-- base58Prefixes[PUBKEY_ADDRESS] = list_of(111);
-- base58Prefixes[SCRIPT_ADDRESS] = list_of(196);
-- base58Prefixes[SECRET_KEY] = list_of(239);
-- base58Prefixes[EXT_PUBLIC_KEY] = list_of(0x04)(0x35)(0x87)(0xCF);
-- base58Prefixes[EXT_SECRET_KEY] = list_of(0x04)(0x35)(0x83)(0x94);
-+ base58Prefixes[PUBKEY_ADDRESS] = std::vector<unsigned char>(1,111);
-+ base58Prefixes[SCRIPT_ADDRESS] = std::vector<unsigned char>(1,196);
-+ base58Prefixes[SECRET_KEY] = std::vector<unsigned char>(1,239);
-+ base58Prefixes[EXT_PUBLIC_KEY] = boost::assign::list_of(0x04)(0x35)(0x87)(0xCF).convert_to_container<std::vector<unsigned char> >();
-+ base58Prefixes[EXT_SECRET_KEY] = boost::assign::list_of(0x04)(0x35)(0x83)(0x94).convert_to_container<std::vector<unsigned char> >();
-
- convertSeed6(vFixedSeeds, pnSeed6_test, ARRAYLEN(pnSeed6_test));
-