summaryrefslogtreecommitdiff
path: root/net-p2p/go-ipfs/go-ipfs-0.12.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/go-ipfs/go-ipfs-0.12.2.ebuild')
-rw-r--r--net-p2p/go-ipfs/go-ipfs-0.12.2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/net-p2p/go-ipfs/go-ipfs-0.12.2.ebuild b/net-p2p/go-ipfs/go-ipfs-0.12.2.ebuild
index 22c0d76d8e5b..2c9295fc8135 100644
--- a/net-p2p/go-ipfs/go-ipfs-0.12.2.ebuild
+++ b/net-p2p/go-ipfs/go-ipfs-0.12.2.ebuild
@@ -8,6 +8,7 @@ inherit bash-completion-r1 go-module systemd
DESCRIPTION="Main implementation of IPFS"
HOMEPAGE="https://ipfs.io/"
SRC_URI="https://github.com/ipfs/go-ipfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# After dropped Go patch, might be able to use upstream vendor tarball
SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
@@ -40,7 +41,7 @@ src_compile() {
go build "${mygoargs[@]}" -o ipfs ./cmd/ipfs || die
go build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch || die
- ./ipfs commands completion bash > ipfs-completion.bash || die
+ IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
}
src_test() {