summaryrefslogtreecommitdiff
path: root/net-p2p/deluge/deluge-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/deluge/deluge-9999.ebuild')
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild113
1 files changed, 69 insertions, 44 deletions
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 344df118563b..2ebeca0f434a 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=1
-inherit xdg distutils-r1 systemd
+inherit distutils-r1 systemd xdg
DESCRIPTION="BitTorrent client with a client/server model"
HOMEPAGE="https://deluge-torrent.org/"
@@ -14,30 +15,39 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.deluge-torrent.org/${PN}"
else
- SRC_URI="http://download.deluge-torrent.org/source/2.0/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~ppc ~x86"
+ SRC_URI="http://download.deluge-torrent.org/source/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~amd64"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="console gtk libnotify sound webinterface"
+IUSE="console gui libnotify sound webinterface"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
- libnotify? ( gtk )
- sound? ( gtk )
+ libnotify? ( gui )
+ sound? ( gui )
"
-DEPEND="
- net-libs/libtorrent-rasterbar:=[python,${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/wheel[${PYTHON_USEDEP}]
- ')
+BDEPEND="
dev-util/intltool
- acct-group/deluge
- acct-user/deluge"
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/pytest-twisted-1.13.4-r1[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
RDEPEND="
+ acct-group/deluge
+ acct-user/deluge
net-libs/libtorrent-rasterbar:=[python,${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
+ gui? (
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
@@ -45,32 +55,19 @@ RDEPEND="
dev-python/pyxdg[${PYTHON_USEDEP}]
dev-python/rencode[${PYTHON_USEDEP}]
dev-python/setproctitle[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
|| (
>=dev-python/twisted-17.1.0[ssl(-),${PYTHON_USEDEP}]
>=dev-python/twisted-17.1.0[crypt(-),${PYTHON_USEDEP}]
)
>=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( x11-libs/libnotify )
- )
dev-python/mako[${PYTHON_USEDEP}]
- ')"
+ ')
+"
-PATCHES=(
- "${FILESDIR}/${PN}-2.0.3-setup.py.patch"
- "${FILESDIR}/${PN}-2.0.3-UI-status.patch"
-)
+distutils_enable_tests pytest
python_prepare_all() {
local args=(
- -e "/Compiling po file/a \\\tuptoDate = False"
- )
- sed -i "${args[@]}" -- 'setup.py' || die
- args=(
-e 's|"new_release_check": True|"new_release_check": False|'
-e 's|"check_new_releases": True|"check_new_releases": False|'
-e 's|"show_new_releases": True|"show_new_releases": False|'
@@ -80,13 +77,36 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-esetup.py() {
- # bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
- # Override this call from the distutils-r1 eclass.
- # This does not respect the distutils-r1 API. DONOT copy this example.
- set -- "${PYTHON}" setup.py "$@"
- echo "$@"
- "$@" || die
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Upstream CI/CD skips these and they seem to intentionally segfault to collect core dumps...
+ deluge/plugins/Stats/deluge_stats/tests/test_stats.py
+ # Skipped upstream
+ deluge/tests/test_security.py
+ )
+ local EPYTEST_DESELECT=(
+ # Skipped upstream
+ 'deluge/plugins/WebUi/deluge_webui/tests/test_plugin_webui.py::TestWebUIPlugin::test_enable_webui'
+ 'deluge/tests/test_torrent.py::TestTorrent::test_torrent_error_resume_data_unaltered'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_seo_svg_with_sni'
+ # never returns
+ 'deluge/tests/test_ui_entry.py::TestConsoleScriptEntryWithDaemon'
+ # failing network(?)-related tests, even with sandbox disabled
+ 'deluge/tests/test_common.py::TestCommon::test_is_interface'
+ # fails
+ 'deluge/tests/test_core.py::TestCore::test_pause_torrents'
+ # fails because of network sandbox
+ 'deluge/tests/test_core.py::TestCore::test_test_listen_port'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_deluge_png'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico_hebrew'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico_with_redirect'
+ # segfaults with FEATURES="network-sandbox"
+ 'deluge/tests/test_core.py::TestCore::test_pause_torrent'
+ )
+
+ # dev-python/pytest-twisted has disabled autoloading
+ epytest -m "not (todo or gtkui)" -p pytest_twisted -v
}
python_install_all() {
@@ -96,13 +116,18 @@ python_install_all() {
rm "${ED}/usr/bin/deluge-console" || die
rm "${ED}/usr/share/man/man1/deluge-console.1" ||die
fi
- if ! use gtk ; then
+ if ! use gui ; then
rm -r "${D}/$(python_get_sitedir)/deluge/ui/gtk3/" || die
rm -r "${ED}/usr/share/icons/" || die
rm "${ED}/usr/bin/deluge-gtk" || die
rm "${ED}/usr/share/man/man1/deluge-gtk.1" || die
- rm "${ED}/usr/share/applications/deluge.desktop" || die
+ else
+ mkdir -p "${ED}/usr/share/applications/" || die
+ cp "${WORKDIR}/${P}/deluge/ui/data/share/applications/deluge.desktop" "${ED}/usr/share/applications/" || die
+ mkdir -p "${ED}/usr/share/metainfo" || die
+ cp "${WORKDIR}/${P}/deluge/ui/data/share/appdata/deluge.appdata.xml" "${ED}/usr/share/metainfo/" || die
fi
+
if use webinterface; then
newinitd "${FILESDIR}/deluge-web.init-2" deluge-web
newconfd "${FILESDIR}/deluge-web.conf" deluge-web
@@ -113,6 +138,7 @@ python_install_all() {
rm "${ED}/usr/bin/deluge-web" || die
rm "${ED}/usr/share/man/man1/deluge-web.1" || die
fi
+
newinitd "${FILESDIR}"/deluged.init-2 deluged
newconfd "${FILESDIR}"/deluged.conf-2 deluged
systemd_newunit "${FILESDIR}"/deluged.service-2 deluged.service
@@ -125,9 +151,8 @@ pkg_postinst() {
xdg_pkg_postinst
elog
- elog "If, after upgrading, deluge doesn't work, please remove the"
- elog "'~/.config/deluge' directory and try again, but make a backup"
- elog "first!"
+ elog "If, after upgrading, deluge doesn't work please back up and then"
+ elog "remove your '~/.config/deluge' directory and try again"
elog
elog "To start the daemon either run 'deluged' as user"
elog "or modify /etc/conf.d/deluged and run"
@@ -139,6 +164,6 @@ pkg_postinst() {
elog "happens in /etc/systemd/system/deluged.service.d/00gentoo.conf"
elog "and /etc/systemd/system/deluge-web.service.d/00gentoo.conf"
elog
- elog "For more information look at https://dev.deluge-torrent.org/wiki/Faq"
+ elog "For more information see https://dev.deluge-torrent.org/wiki/Faq"
elog
}