summaryrefslogtreecommitdiff
path: root/net-nntp/tin
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp/tin')
-rw-r--r--net-nntp/tin/Manifest2
-rw-r--r--net-nntp/tin/tin-2.6.3.ebuild122
2 files changed, 124 insertions, 0 deletions
diff --git a/net-nntp/tin/Manifest b/net-nntp/tin/Manifest
index f858fa1f0622..2ec126f35beb 100644
--- a/net-nntp/tin/Manifest
+++ b/net-nntp/tin/Manifest
@@ -1,6 +1,8 @@
AUX tin-2.6.2-c99.patch 2650 BLAKE2B 0afaeb921397abd451dd166947a15ccb493bff51872a9fbb10cfff15b6dac77b9c9c9f8343a63e0eaf419c50e0151376bc461aa233cbea9680e198c0f30bc699 SHA512 886fbb0d54690373f4abb7ac8bbdd417883db9d0f21b41c5aff0e1e52b787cf67f0603682679380a93d80f369d626db1ec7000c925fdf8ec1c9b5a092ae00687
AUX tin-2.6.2-gnutls.patch 653 BLAKE2B fd5ad80b1f2e5c5307e28e513f2aaf9cbd17f12517aed07298aaa54dc85a26aa28f4a091841fd2efa154b9acc4fa7749d575ec3aba60e4008f9c1ef533a50120 SHA512 d372ce615a18ab5cc67ec69e71870e5073937e8a59f55cf7e5a43271cd9eb55ae379e875b8656b2140403e23792df1844b05ff234cbed18883f59a445d11d21f
DIST tin-2.6.2.tar.xz 1598732 BLAKE2B 0e5bac9a711fb69e64d64b4f0c070d456f38f727e7b7aa794ad5ada8695c2174023964b8f07d2e7d6add51cf0c7c3102965bef653a7e873275747145cb70dbe2 SHA512 4c9e0edb3268d57fb89d9d53a90e8a5ba73da7c1da63c834224bed0f763502a7c3dd325351d3e57b1ddcb57494a84228cc38f227c49300b759fad8d112b1cac1
+DIST tin-2.6.3.tar.xz 1639192 BLAKE2B dba26c5e5fe0e331e069a22ce3241c00e7e01f582d00a38e55e2fe33c93f98d99c47e9d04e0660b40535a8b11e63789bc91df1b22dacd62405ee716a003c07dd SHA512 e8b474849e3330475e92b7c578ffe2f29f022303be266d39493e58b7227d9a5ee3915812c1806f52358c07f91d6119810498db906d2da7ffe035feba0e340a42
EBUILD tin-2.6.2-r1.ebuild 2685 BLAKE2B 11a451371d2cee52e345132eec6e897434c7bf0e0a85532cbf0dd1cc3731e151e2a94e0e129dcf407ddb6a5b4fa8b598a0d39f7ecbb89177b5f0adc098d1ca25 SHA512 9d93ca00dda9c9580c1f8057097ffcd5af95163d8742c25f934c90e7befb31190c27e6cc2e4b63aa319204045292ccd230b251139ce561597e54c2aa50ae4c6f
EBUILD tin-2.6.2-r2.ebuild 2787 BLAKE2B 4974ed2b15b1d2efee1d13e4c389eb7bc7f95821716a140488e0fc8e63f5d4df4b9dcd140e4c7cdd8b7e92ecd388230aab75db4760c1b3e9e4719cb1927f46e4 SHA512 0ff24f6d9a1a0e2e345f4baf38823d7e0881a264b7f18e8d34199a4ea69e9fd16cf397c312d89323d17fe0dd3e8519afa9e590fce4e86316bd8d22dfe273056d
+EBUILD tin-2.6.3.ebuild 2704 BLAKE2B 71a9810bcd17a3a9486bf4bdd56ca209d3715d576270d2218ad98748b87f652387752414f4b7fc2a6531278702f1f99cdbb04293c9fe32cadb2f96d66a813430 SHA512 e557e73142d9d5ad0efcaeb2801fe3d83d2038b7b93fd7e23d3f2759d6246bb916f497ea0e446f542bbfc3ab17a3afe18cbe2b0c30f13f2e655b2c106d80d0c3
MISC metadata.xml 567 BLAKE2B 25916692a1170d644125e756c5165c39ae91c663bcb2cb6eee21e6aca3852acb4eedc7ac6b3efdd1506a474c3e3314496018e84c99e218d1e9a92d4bbe6c2b99 SHA512 eabaa6400110777a838ece4787f6978eb2c4dd1bdf4051e498190e0607550ad8bf18ac63fd946635d2ea19849ea015a383da9bed35cfc940a2cae9b7f1329c61
diff --git a/net-nntp/tin/tin-2.6.3.ebuild b/net-nntp/tin/tin-2.6.3.ebuild
new file mode 100644
index 000000000000..0b301a45df40
--- /dev/null
+++ b/net-nntp/tin/tin-2.6.3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/stable/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug gnutls gpg libtls nls sasl socks5 ssl"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/libpcre2:=
+ dev-libs/uulib
+ sys-libs/ncurses:=
+ virtual/libiconv
+ cancel-locks? ( >=net-libs/canlock-3.0:= )
+ gpg? ( app-crypt/gnupg )
+ nls? ( virtual/libintl )
+ sasl? ( net-misc/gsasl[client] )
+ socks5? ( net-proxy/dante )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ libtls? ( dev-libs/libretls:= )
+ !libtls? ( dev-libs/openssl:= )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/yacc
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Windows only (bug #900278)
+ memset_s
+)
+
+DOCS=(
+ README{,.MAC,.WIN}
+ doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW,filtering}
+)
+
+src_configure() {
+ tc-export AR CC RANLIB
+ tc-export_build_env
+
+ # The build incorrectly discards its local -I if $CPPFLAGS is set.
+ if [[ -n ${BUILD_CPPFLAGS} ]]; then
+ BUILD_CPPFLAGS+=' -I$(INCDIR)'
+ fi
+
+ local myeconfargs=(
+ $(use_enable cancel-locks)
+ $(use_with cancel-locks canlock)
+
+ $(use_enable debug)
+ $(use_enable gpg pgp-gpg)
+ $(use_enable nls)
+ $(use_with socks5 socks)
+ --disable-mime-strict-charset
+ --enable-nntp
+ --enable-prototypes
+ --without-pcre
+ --with-pcre2-config
+ --with-coffee # easter egg :)
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.io}}"
+ --with-screen=ncursesw
+ )
+
+ if use ssl; then
+ if use gnutls; then
+ myeconfargs+=( --with-nntps=gnutls )
+ elif use libtls; then
+ myeconfargs+=( --with-nntps=libtls )
+ else
+ myeconfargs+=( --with-nntps=openssl )
+ fi
+ fi
+
+ myeconfargs+=(
+ # set default paths for utilities
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ --with-gpg="${EPREFIX}"/usr/bin/gpg
+ --with-ispell="${EPREFIX}"/usr/bin/aspell
+ --with-mailer="${EPREFIX}"/bin/mail
+ --with-sum="${EPREFIX}"/usr/bin/sum
+
+ # set default paths for directories
+ --with-libdir="${EPREFIX}"/var/lib/news
+ --with-spooldir="${EPREFIX}"/var/spool/news
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # To build from the root dir you have to call `make build`, not just `make`.
+ emake build
+}
+
+src_install() {
+ default
+
+ emake DESTDIR="${D}" install_sysdefs
+ emake -C src DESTDIR="${D}" install_nls_man
+
+ dodoc doc/{*.sample,*.txt}
+}
+
+pkg_postinst() {
+ optfeature "spell checker support" app-text/aspell
+}