summaryrefslogtreecommitdiff
path: root/net-news/yydecode/yydecode-0.2.10-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/yydecode/yydecode-0.2.10-r3.ebuild')
-rw-r--r--net-news/yydecode/yydecode-0.2.10-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-news/yydecode/yydecode-0.2.10-r3.ebuild b/net-news/yydecode/yydecode-0.2.10-r3.ebuild
new file mode 100644
index 000000000000..f3cf3e6ad416
--- /dev/null
+++ b/net-news/yydecode/yydecode-0.2.10-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A decoder for yENC format, popular on Usenet"
+HOMEPAGE="https://yydecode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yydecode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.10-fix-strcmp-not-found.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s/t3.sh//" -e "s/t7.sh//" -i checks/Makefile.in || die
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/898078
+ #
+ # Upstream has been dead since 2003. No bug reported.
+ filter-lto
+ default
+}