summaryrefslogtreecommitdiff
path: root/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/rsstool/rsstool-1.0.1_rc2.ebuild')
-rw-r--r--net-news/rsstool/rsstool-1.0.1_rc2.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/net-news/rsstool/rsstool-1.0.1_rc2.ebuild b/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
index f060be09ef30..b662c685145f 100644
--- a/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
+++ b/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -10,20 +10,22 @@ MY_P=${PN}-${PV/_}
DESCRIPTION="cmdline tool to read, parse, merge, and write RSS (and Atom) feeds"
HOMEPAGE="http://rsstool.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
+S="${WORKDIR}"/${MY_P}-src/src
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
-RDEPEND="dev-libs/libxml2
- net-misc/curl"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}-src/src
+RDEPEND="
+ dev-libs/libxml2
+ net-misc/curl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
src_prepare() {
+ default
+
sed -e '1i#!/bin/bash' -i configure || die
}
@@ -34,5 +36,6 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" BINDIR="/usr/bin" install
- dohtml ../{changes,faq,readme}.html
+ docinto html
+ dodoc ../{changes,faq,readme}.html
}