summaryrefslogtreecommitdiff
path: root/net-news/liferea/liferea-1.12.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/liferea/liferea-1.12.3.ebuild')
-rw-r--r--net-news/liferea/liferea-1.12.3.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/net-news/liferea/liferea-1.12.3.ebuild b/net-news/liferea/liferea-1.12.3.ebuild
deleted file mode 100644
index 5ab02798eae9..000000000000
--- a/net-news/liferea/liferea-1.12.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GNOME2_EAUTORECONF="yes"
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit gnome2 pax-utils python-single-r1
-
-MY_P=${P/_/-}
-
-DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo feeds"
-HOMEPAGE="https://lzone.de/liferea/"
-SRC_URI="https://github.com/lwindolf/${PN}/releases/download/v${PV/_/-}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-db/sqlite-3.7.0:3
- >=dev-libs/glib-2.28.0:2
- dev-libs/gobject-introspection
- dev-libs/json-glib
- >=dev-libs/libpeas-1.0.0[gtk,python,${PYTHON_SINGLE_USEDEP}]
- >=dev-libs/libxml2-2.6.27:2
- >=dev-libs/libxslt-1.1.19
- gnome-base/gsettings-desktop-schemas
- >=net-libs/libsoup-2.42:2.4
- net-libs/webkit-gtk:4
- x11-libs/gtk+:3
- >=x11-libs/pango-1.4.0"
-DEPEND="${RDEPEND}
- dev-util/intltool
- virtual/pkgconfig"
-
-S="${WORKDIR}"/${MY_P}
-
-src_configure() {
- gnome2_src_configure --disable-schemas-compile
-}
-
-src_compile() {
- # Workaround crash in libwebkit2gtk-4.0.so
- # https://bugs.gentoo.org/704594
- WEBKIT_DISABLE_COMPOSITING_MODE=1 \
- gnome2_src_compile
-}
-
-src_install() {
- gnome2_src_install
-
- # bug #338213
- # Uses webkit's JIT. Needs mmap('rwx') to generate code in runtime.
- # MPROTECT policy violation. Will sit here until webkit will
- # get optional JIT.
- pax-mark m "${ED%/}"/usr/bin/liferea
-}
-
-pkg_postinst() {
- elog "If you want to enhance the functionality of this package,"
- elog "you should consider installing:"
- elog " net-misc/networkmanager"
-}