summaryrefslogtreecommitdiff
path: root/net-news/canto-daemon/canto-daemon-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/canto-daemon/canto-daemon-0.9.1.ebuild')
-rw-r--r--net-news/canto-daemon/canto-daemon-0.9.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-news/canto-daemon/canto-daemon-0.9.1.ebuild b/net-news/canto-daemon/canto-daemon-0.9.1.ebuild
new file mode 100644
index 000000000000..16b7ea1a8d7c
--- /dev/null
+++ b/net-news/canto-daemon/canto-daemon-0.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="xml(+),threads(+)"
+inherit distutils-r1 multilib
+
+DESCRIPTION="Daemon part of Canto-NG RSS reader"
+HOMEPAGE="http://codezen.org/canto-ng/"
+SRC_URI="http://codezen.org/static/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/canto-next-${PV}"
+
+python_prepare_all() {
+ # Respect libdir during plugins installation
+ sed -i -e "s:lib/canto:$(get_libdir)/canto:" setup.py || die
+
+ distutils-r1_python_prepare_all
+}